aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/migemo-emacs20/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-03-28 06:43:48 +0800
committersf <sf@FreeBSD.org>2001-03-28 06:43:48 +0800
commita1302ed82a25ee3a352ca3358a5ea1d08d3f600e (patch)
treea46f910e20cb078433960bc5c4361eb82540cb76 /japanese/migemo-emacs20/Makefile
parenta9306076de0bc02686556ff6a036d2ce6a34e824 (diff)
downloadfreebsd-ports-gnome-a1302ed82a25ee3a352ca3358a5ea1d08d3f600e.tar.gz
freebsd-ports-gnome-a1302ed82a25ee3a352ca3358a5ea1d08d3f600e.tar.zst
freebsd-ports-gnome-a1302ed82a25ee3a352ca3358a5ea1d08d3f600e.zip
o install docs under share/doc/migemo.
o make this port MASTER of upcoming migemo-xemacs21. PR: 26124 Submitted by: maintainer
Diffstat (limited to 'japanese/migemo-emacs20/Makefile')
-rw-r--r--japanese/migemo-emacs20/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/japanese/migemo-emacs20/Makefile b/japanese/migemo-emacs20/Makefile
index cbf2b4fccc32..eb364ace05e6 100644
--- a/japanese/migemo-emacs20/Makefile
+++ b/japanese/migemo-emacs20/Makefile
@@ -7,20 +7,34 @@
PORTNAME= migemo
PORTVERSION= 0.21
+PORTREVISION= 1
CATEGORIES= japanese elisp
MASTER_SITES= http://migemo.namazu.org/stable/
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= nobutaka@nobutaka.com
-BUILD_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME} \
- ${NONEXISTENT}:${SKK_PORT_DIR}:extract
+EMACS_PORT_NAME?= emacs20
+
+.if (${EMACS_PORT_NAME} == "xemacs21-mule")
+EMACS_PACKAGESDIR= lib/xemacs/site-packages
+
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS= ${LOCALBASE}/${EMACS_PACKAGESDIR}/lisp/apel/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.else
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
RUN_DEPENDS= ${LOCALBASE}/${EMACS_LIBDIR_WITH_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+.endif
+BUILD_DEPENDS+= ${NONEXISTENT}:${SKK_PORT_DIR}:extract
USE_PERL5= yes
-USE_AUTOCONF= yes
+USE_AUTOMAKE= yes
+
+CONFIGURE_ARGS= --with-emacs=${EMACS_CMD}
+.if (${EMACS_PORT_NAME} == "xemacs21-mule")
+CONFIGURE_ARGS+= --with-lispdir=${PREFIX}/${EMACS_LIBDIR}/site-lisp
+.endif
-EMACS_PORT_NAME=emacs20
SKK_PORT_DIR= ${PORTSDIR}/japanese/skk-jisyo
.include <bsd.port.pre.mk>