aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mikachan-ttfonts/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
committerbapt <bapt@FreeBSD.org>2015-03-22 07:05:19 +0800
commitfe5a7e4bee2fc7a40343278a44de77847b5c91c5 (patch)
treeb9556c9042a9d20d7c71f49869f39f95afc00052 /japanese/mikachan-ttfonts/Makefile
parent9167139629893ea7664f3b1cf93141ff1eeb82b4 (diff)
downloadfreebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.tar.gz
freebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.tar.zst
freebsd-ports-gnome-fe5a7e4bee2fc7a40343278a44de77847b5c91c5.zip
Make fonts repecting XDG
Xorg is now looking in ${LOCALBASE}/share/fonts by default Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1)) Large cleanup on lots of font ports All fonts are now properly dynamically generating fonts.dir and fonts.scale instead of sometime overwriting existing ones) All fonts are generating fontconfig's cache Improve consistency in fonts ports
Diffstat (limited to 'japanese/mikachan-ttfonts/Makefile')
-rw-r--r--japanese/mikachan-ttfonts/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/japanese/mikachan-ttfonts/Makefile b/japanese/mikachan-ttfonts/Makefile
index 7ac3ccc019e0..a92f50f84c15 100644
--- a/japanese/mikachan-ttfonts/Makefile
+++ b/japanese/mikachan-ttfonts/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mikachan-ttfonts
PORTVERSION= 9.1
+PORTREVISION= 1
CATEGORIES= japanese x11-fonts
MASTER_SITES= http://mikachan.sourceforge.jp/
DISTNAME= ver${PORTVERSION}
@@ -13,6 +14,7 @@ COMMENT= Handwritten Japanese TrueType fonts by Mika-chan
EXTRACT_DEPENDS= lha:${PORTSDIR}/archivers/lha
+USES= fonts
NO_CDROM= Do not sell distfile
EXTRACT_CMD= lha
EXTRACT_BEFORE_ARGS= pq
@@ -21,15 +23,13 @@ DIST_SUBDIR= ${PORTNAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
MAKE_ENV= FONTSDIR=${FONTSDIR}
-PLIST_SUB= FONTSDIR=${FONTSDIR}
-FONTSDIR= lib/X11/fonts/TrueType
+FONTNAME= TrueType
do-install:
- ${SETENV} PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
${INSTALL_DATA} \
${WRKDIR}/mika.ttf ${FILESDIR}/fonts.dir.mika \
- ${STAGEDIR}${PREFIX}/${FONTSDIR}
- ${SETENV} PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${STAGEDIR}${FONTSDIR}
.include <bsd.port.mk>