aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mule-sj3/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-08-19 19:56:51 +0800
committerasami <asami@FreeBSD.org>1996-08-19 19:56:51 +0800
commit0e6890c42f524372d072cd3efcea8aab7c61f7d7 (patch)
tree75490364b9d85e166e2e318d433f57850eebe28e /japanese/mule-sj3/Makefile
parentb53606a3db055199147016656c5acef1077b4304 (diff)
downloadfreebsd-ports-gnome-0e6890c42f524372d072cd3efcea8aab7c61f7d7.tar.gz
freebsd-ports-gnome-0e6890c42f524372d072cd3efcea8aab7c61f7d7.tar.zst
freebsd-ports-gnome-0e6890c42f524372d072cd3efcea8aab7c61f7d7.zip
A mule that uses sj3.
Submitted by: Hidekazu Kuroki <hidekazu@cs.titech.ac.jp>
Diffstat (limited to 'japanese/mule-sj3/Makefile')
-rw-r--r--japanese/mule-sj3/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/japanese/mule-sj3/Makefile b/japanese/mule-sj3/Makefile
new file mode 100644
index 000000000000..92ca8cafc1e9
--- /dev/null
+++ b/japanese/mule-sj3/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mule with sj3
+# Version required: 2.3
+# Date created: 8 August 1996
+# Whom: Hidekazu Kuroki <hidekazu@cs.titech.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= mule-2.3
+PKGNAME= jp-smule-2.3
+CATEGORIES+= japanese editors
+MASTER_SITES= ftp://etlport.etl.go.jp/pub/mule/ \
+ ftp://ftp.cs.buffalo.edu/pub/mule/ \
+ ftp://sh.wide.ad.jp/JAPAN/mule/ \
+ ftp://ftp.funet.fi/pub/gnu/emacs/mule/
+
+MAINTAINER= hidekazu@cs.titech.ac.jp
+
+BUILD_DEPENDS= sj3serv:${PORTSDIR}/japanese/sj3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= i386--freebsd --with-x-toolkit \
+ --sj3 --terminal-face \
+ --locallisppath=${PREFIX}/lib/mule/site-lisp:${PREFIX}/share/emacs/site-lisp
+STRIP=
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+post-install:
+# note that rcs-checkn and any2ps are scripts
+ strip ${PREFIX}/bin/b2m
+ strip ${PREFIX}/bin/coco
+ strip ${PREFIX}/bin/ctags
+ strip ${PREFIX}/bin/etags
+ strip ${PREFIX}/bin/m2ps
+ strip ${PREFIX}/bin/mule-19.28
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/coco.1
+ gzip -9nf ${PREFIX}/man/man1/ctags.1
+ gzip -9nf ${PREFIX}/man/man1/etags.1
+ gzip -9nf ${PREFIX}/man/man1/m2ps.1
+ gzip -9nf ${PREFIX}/man/man1/mule.1
+.endif
+
+.include <bsd.port.mk>