aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/mutt-devel/Makefile
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>1999-09-06 04:04:07 +0800
committersada <sada@FreeBSD.org>1999-09-06 04:04:07 +0800
commit54b3d54e94ae5c7f153264dd311f3c8754d98f22 (patch)
tree736eaee54f5e07b7ec7052c7d96123f6e2bc42df /japanese/mutt-devel/Makefile
parentbee2d76b1b8cbb8fd24eb484b651295344145dd7 (diff)
downloadfreebsd-ports-gnome-54b3d54e94ae5c7f153264dd311f3c8754d98f22.tar.gz
freebsd-ports-gnome-54b3d54e94ae5c7f153264dd311f3c8754d98f22.tar.zst
freebsd-ports-gnome-54b3d54e94ae5c7f153264dd311f3c8754d98f22.zip
Text-based powerful mail client with Japanize patch.
PR is about version 0.95 but submitter sent new version 1.0-b1 to ports-jp ML and I'll commit it. PR: 12451 Submitted by: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
Diffstat (limited to 'japanese/mutt-devel/Makefile')
-rw-r--r--japanese/mutt-devel/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/japanese/mutt-devel/Makefile b/japanese/mutt-devel/Makefile
new file mode 100644
index 000000000000..2bc27a3936f6
--- /dev/null
+++ b/japanese/mutt-devel/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ja-mutt
+# Version required: 1.0pre1i
+# Date created: 5 Sep 1999
+# Whom: IWASHITA Yoji <shuna@pop16.odn.ne.jp>
+#
+# $FreeBSD$
+#
+
+DISTNAME= mutt-1.0pre1i
+PKGNAME= ja-mutt-1.0b1.j0
+CATEGORIES= japanese mail
+MASTER_SITES= ftp://ftp.guug.de/pub/mutt/ \
+ ftp://ftp.guug.de/pub/mutt/historic/ \
+ ftp://ftp.gbnet.net/pub/mutt-international/
+
+PATCH_SITES= http://home.sprintmail.com/~kikutani/slang/
+PATCHFILES= mutt-1.0pre1i.jp0.pat.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= shuna@pop16.odn.ne.jp
+
+LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang
+BUILD_DEPENDS= ${PREFIX}/bin/msgfmt:${PORTSDIR}/devel/gettext \
+ autoconf:${PORTSDIR}/devel/autoconf \
+ automake:${PORTSDIR}/devel/automake
+RUN_DEPENDS= urlview:${PORTSDIR}/textproc/urlview
+
+DIST_SUBDIR= mutt
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/mutt-1.0pre1
+CONFIGURE_ARGS= --with-slang --enable-locales-fix --with-included-gettext \
+ --enable-flock --disable-fcntl \
+ --sysconfdir=${PREFIX}/share/mutt \
+ --with-sharedir=${PREFIX}/share/mutt \
+ --with-docdir=${PREFIX}/share/doc/mutt \
+ --enable-pop --enable-imap
+
+MAN1= mutt.1 mutt_dotlock.1
+
+pre-configure:
+ (cd ${WRKSRC}; autoconf)
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/contrib/sample.muttrc ${PREFIX}/share/doc/mutt
+ ${INSTALL_DATA} ${WRKSRC}/contrib/Mush.rc ${PREFIX}/share/doc/mutt
+ ${INSTALL_DATA} ${WRKSRC}/contrib/Pine.rc ${PREFIX}/share/doc/mutt
+
+.include <bsd.port.mk>