aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/nethack34/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-08-30 19:07:40 +0800
committerasami <asami@FreeBSD.org>1996-08-30 19:07:40 +0800
commit628b763ba9d9df288193fed79e85cdf4ffc926ae (patch)
treed538eef5d91b87c42c89e2d6dee9a66588d6f28d /japanese/nethack34/Makefile
parent20f1aa4cd6d11dda356590c39a7e1745173d33f9 (diff)
downloadfreebsd-ports-gnome-628b763ba9d9df288193fed79e85cdf4ffc926ae.tar.gz
freebsd-ports-gnome-628b763ba9d9df288193fed79e85cdf4ffc926ae.tar.zst
freebsd-ports-gnome-628b763ba9d9df288193fed79e85cdf4ffc926ae.zip
Upgrade, 1.0.3 -> 1.0.5.2.2. It's beta, but who cares, it's nethack! :)
Submitted by: max@sfc.wide.ad.jp
Diffstat (limited to 'japanese/nethack34/Makefile')
-rw-r--r--japanese/nethack34/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/japanese/nethack34/Makefile b/japanese/nethack34/Makefile
index c116276648a9..c3e8a294b13e 100644
--- a/japanese/nethack34/Makefile
+++ b/japanese/nethack34/Makefile
@@ -1,23 +1,24 @@
# New ports collection makefile for: nethack
-# Version required: 3.1.3 + 1.0.3
+# Version required: 3.2.1 + 1.0.5.2
# Date created: 13 February 1995
# Whom: asami
#
-# $Id: Makefile,v 1.3 1995/06/19 04:25:39 asami Exp $
+# $Id: Makefile,v 1.4 1996/06/26 22:22:33 gpalmer Exp $
#
-DISTNAME= nethack3.1.3
-PKGNAME= jp-nethack-1.0.3
+DISTNAME= nethack-3.2.1
+PKGNAME= jp-nethack-1.0.5.2.2
CATEGORIES+= japanese games
MASTER_SITES= ftp://ftp.uu.net/usenet/comp.sources.games/
-EXTRACT_SUFX= .tar.Z
PATCH_SITES= ftp://mitsuko.jaist.ac.jp/pub/jnethack/
-PATCHFILES= jnethack-1.0.3.gz
+PATCHFILES= jnethack-1.0.5.1.gz jn-1.0.5.2-beta-960821.gz \
+ jn-1.0.5.2-beta-960822.gz
-MAINTAINER= asami@FreeBSD.ORG
+MAINTAINER= max@sfc.wide.ad.jp
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
-WRKSRC= ${WRKDIR}/nethack313
USE_GMAKE= yes
SHELL= /bin/sh
FETCH_BEFORE_ARGS= -NP
@@ -26,13 +27,15 @@ pre-configure:
@cd ${WRKSRC}/sys/unix; ${SHELL} setup.sh
pre-install:
- @cd ${WRKSRC}/doc; ${MAKE} manpages
-
+ @cd ${WRKSRC}/doc; chmod 644 *.6
+ @cd ${WRKSRC}/doc; ${MAKE} PREFIX=${PREFIX} manpages
post-install:
+.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man6/dgn_comp.6
gzip -9nf ${PREFIX}/man/man6/lev_comp.6
gzip -9nf ${PREFIX}/man/man6/nethack.6
gzip -9nf ${PREFIX}/man/man6/recover.6
+.endif
.include <bsd.port.mk>