aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/nkf
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2009-04-12 21:42:08 +0800
committernork <nork@FreeBSD.org>2009-04-12 21:42:08 +0800
commit7050bdc5d5f2f45ee9c64f16337d08687f1ba549 (patch)
treeecdd5af18b5f809000ab4f3be27625401fcc8225 /japanese/nkf
parente86636a6e0463d9674147ca573ef4dd62a30a714 (diff)
downloadfreebsd-ports-gnome-7050bdc5d5f2f45ee9c64f16337d08687f1ba549.tar.gz
freebsd-ports-gnome-7050bdc5d5f2f45ee9c64f16337d08687f1ba549.tar.zst
freebsd-ports-gnome-7050bdc5d5f2f45ee9c64f16337d08687f1ba549.zip
Update to 2.0.9.
PR: ports/132453 Submitted by: Tsurutani Naoki turutani at scphys.kyoto-u.ac.jp
Diffstat (limited to 'japanese/nkf')
-rw-r--r--japanese/nkf/Makefile7
-rw-r--r--japanese/nkf/distinfo6
-rw-r--r--japanese/nkf/files/patch-aa40
3 files changed, 28 insertions, 25 deletions
diff --git a/japanese/nkf/Makefile b/japanese/nkf/Makefile
index 513459c68fa8..7a22fe1a3879 100644
--- a/japanese/nkf/Makefile
+++ b/japanese/nkf/Makefile
@@ -6,19 +6,16 @@
#
PORTNAME= nkf
-PORTVERSION= 2.0.7
+PORTVERSION= 2.0.9
PORTEPOCH= 1
CATEGORIES?= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR= ${PORTNAME}/20770
+MASTER_SITE_SUBDIR= ${PORTNAME}/37177
PKGNAMEPREFIX?= ja-
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= nork@FreeBSD.org
COMMENT?= Network Kanji code conversion Filter
-WRKSRC?= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
-
.if ${PKGNAMEPREFIX} != "ja-p5-"
MAN1= nkf.1
MANLANG= "" ja
diff --git a/japanese/nkf/distinfo b/japanese/nkf/distinfo
index 5f6c106f2814..84b4809d45ba 100644
--- a/japanese/nkf/distinfo
+++ b/japanese/nkf/distinfo
@@ -1,3 +1,3 @@
-MD5 (nkf207.tar.gz) = af11dcd3fe71d67831c020e3bfd5073b
-SHA256 (nkf207.tar.gz) = 71d2ba992df209a00bb1dca45e3336729dc16e51b71526bd20f897cc6127a275
-SIZE (nkf207.tar.gz) = 150501
+MD5 (nkf-2.0.9.tar.gz) = 0dadcf178785c87874822a2ff8da9f19
+SHA256 (nkf-2.0.9.tar.gz) = 3b2a972437e425c2c1e2786f20d74deaaf06bb7386eaa2925dfd5a772198f81f
+SIZE (nkf-2.0.9.tar.gz) = 157686
diff --git a/japanese/nkf/files/patch-aa b/japanese/nkf/files/patch-aa
index 8ce6c794964e..86eca49eafa6 100644
--- a/japanese/nkf/files/patch-aa
+++ b/japanese/nkf/files/patch-aa
@@ -1,11 +1,10 @@
---- Makefile.orig Mon Jun 19 23:04:35 2006
-+++ Makefile Sun Jul 2 21:44:28 2006
-@@ -1,17 +1,27 @@
+--- Makefile.orig 2009-01-20 18:49:31.000000000 +0900
++++ Makefile 2009-04-12 22:30:54.667420352 +0900
+@@ -1,15 +1,19 @@
-CC = cc
--CFLAGS = -O
-+PREFIX?= /usr/local
+-CFLAGS = -O -Wall -pedantic
+CC?= cc
-+CFLAGS?= -O -Wall
++CFLAGS?= -O -Wall -pedantic
# CFLAGS = -O3
SHAR = shar
# SHAR = shar -T
@@ -13,22 +12,29 @@
-RM = rm -rf
+PERL?= perl
+RM?= rm -rf
+ VERSION = 2.0.9
+-prefix = /usr/local
++PREFIX?= /usr/local
+INSTALL?= /usr/bin/install
+BSD_INSTALL_PROGRAM?= ${INSTALL} -s -o root -g wheel -m 555
+BSD_INSTALL_MAN?= ${INSTALL} -o root -g wheel -m 444
- VERSION = 207
- nkf : nkf.c config.h utf8tbl.o
- $(CC) $(CFLAGS) -o nkf nkf.c utf8tbl.o
+ nkf : nkf.o utf8tbl.o
+ $(CC) $(CFLAGS) -o nkf nkf.o utf8tbl.o
+ ./nkf -e nkf.1j > nkf.1j.euc
- utf8tbl.o : utf8tbl.c config.h
- $(CC) $(CFLAGS) -c utf8tbl.c
-+
-+install:
-+ ${BSD_INSTALL_PROGRAM} nkf ${PREFIX}/bin
-+ ${BSD_INSTALL_MAN} nkf.1 ${PREFIX}/man/man1/nkf.1
+ nkf.o : nkf.c nkf.h utf8tbl.h config.h
+ $(CC) $(CFLAGS) -c nkf.c
+@@ -31,9 +35,9 @@
+ make test )
+
+ install:
+- cp nkf $(prefix)/bin/
+- cp nkf.1 $(prefix)/man/man1/
+- cp nkf.1j $(prefix)/man/ja/man1/nkf.1
++ ${BSD_INSTALL_PRGRAM} nkf ${PREFIX}/bin/
++ ${BSD_INSTALL_MAN} nkf.1 ${PREFIX}/man/man1/
+ ${BSD_INSTALL_MAN} nkf.1j.euc ${PREFIX}/man/ja/man1/nkf.1
- clean:
- -$(RM) nkf.o nkf nkf.in nkf.out nkf$(VERSION) *~ *.bad utf8tbl.o
+ shar:
+ -mkdir nkf-$(VERSION)