aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/p5-2chproxy
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-11-16 16:51:53 +0800
committerhrs <hrs@FreeBSD.org>2016-11-16 16:51:53 +0800
commit11914e8273690e4bb803581545c3dc3336c12219 (patch)
tree0d2b70e961b341a647a1e6476dc653339198011a /japanese/p5-2chproxy
parentc1540d136a2f6b48d53c53d29af9a0abf651c7a1 (diff)
downloadfreebsd-ports-gnome-11914e8273690e4bb803581545c3dc3336c12219.tar.gz
freebsd-ports-gnome-11914e8273690e4bb803581545c3dc3336c12219.tar.zst
freebsd-ports-gnome-11914e8273690e4bb803581545c3dc3336c12219.zip
Fix wrong lines of SHEBANG_FILES and USE_RC_SUBR.
Spotted by: mat
Diffstat (limited to 'japanese/p5-2chproxy')
-rw-r--r--japanese/p5-2chproxy/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/japanese/p5-2chproxy/Makefile b/japanese/p5-2chproxy/Makefile
index 96bea08247ae..3ea95086111f 100644
--- a/japanese/p5-2chproxy/Makefile
+++ b/japanese/p5-2chproxy/Makefile
@@ -17,18 +17,16 @@ RUN_DEPENDS= p5-HTTP-Daemon>0:www/p5-HTTP-Daemon \
p5-libwww>0:www/p5-libwww
USES= perl5 shebangfix
-SHEBANG_FILES= ${WRKSRC}/${PORTNAME}.pl
+SHEBANG_FILES= ${PORTNAME}.pl
USE_GITHUB= yes
GH_ACCOUNT= yama-natuki
GH_PROJECT= ${PORTNAME}.pl
+USE_RC_SUBR= twochproxy
NO_BUILD= yes
-RC_SUBR= ${WRKDIR}/twochproxy
-SUB_FILES= ${FILESDIR_REL}/twochproxy
-PLIST_FILES= sbin/${PORTNAME}.pl \
- etc/rc.d/twochproxy
+SUB_FILES= twochproxy
+PLIST_FILES= sbin/${PORTNAME}.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKDIR}/twochproxy ${STAGEDIR}${PREFIX}/etc/rc.d
.include <bsd.port.mk>