aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/plain2
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-19 06:35:59 +0800
committerkrion <krion@FreeBSD.org>2003-10-19 06:35:59 +0800
commitfb7cc83cbe7cd5b71f7aad01e89649f771ca2b35 (patch)
tree405cca9caef6194e532e4e552b33d66031f14b86 /japanese/plain2
parent2d8f168b20da99fd3a13bc53699f04a5719e2e9b (diff)
downloadfreebsd-ports-gnome-fb7cc83cbe7cd5b71f7aad01e89649f771ca2b35.tar.gz
freebsd-ports-gnome-fb7cc83cbe7cd5b71f7aad01e89649f771ca2b35.tar.zst
freebsd-ports-gnome-fb7cc83cbe7cd5b71f7aad01e89649f771ca2b35.zip
- Fix build on -current
PR: 58221 Submitted by: Ports Fury
Diffstat (limited to 'japanese/plain2')
-rw-r--r--japanese/plain2/Makefile8
-rw-r--r--japanese/plain2/files/patch-src::macro.c31
2 files changed, 32 insertions, 7 deletions
diff --git a/japanese/plain2/Makefile b/japanese/plain2/Makefile
index 711e4927a166..841037f6ba73 100644
--- a/japanese/plain2/Makefile
+++ b/japanese/plain2/Makefile
@@ -26,12 +26,6 @@ USE_REINPLACE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DBSD -DKANJI -DPICTURE -DHTML -fwritable-strings"
ALL_TARGET= ${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/lib/plain2|${DATADIR}|g' ${BUILD_WRKSRC}/plain2.h
@@ -41,4 +35,4 @@ do-install:
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/lib/*.p2 ${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/plain2/files/patch-src::macro.c b/japanese/plain2/files/patch-src::macro.c
new file mode 100644
index 000000000000..aa8e9b3e65c2
--- /dev/null
+++ b/japanese/plain2/files/patch-src::macro.c
@@ -0,0 +1,31 @@
+--- src/macro.c.orig Sat Oct 18 23:46:14 2003
++++ src/macro.c Sat Oct 18 23:47:36 2003
+@@ -8,7 +8,7 @@
+
+ #include <stdio.h>
+ #include <ctype.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include "plain2.h"
+ #include "macro.h"
+
+@@ -189,9 +189,7 @@
+ buf++;
+ }
+ }
+-putMacro(macroNum, va_alist)
+-int macroNum;
+-va_dcl
++putMacro(int macroNum, char *fmt, ...)
+ {
+ va_list ap;
+ union macroArg {
+@@ -226,7 +224,7 @@
+ }
+ mip = mip->cmac_next;
+ }
+- va_start(ap);
++ va_start(ap, fmt);
+ for (i = 1; i <= maxarg; i++) {
+ switch(argtype[i]) {
+ case ATYPE_VOID: