aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/platex-sjis/Makefile
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>1998-06-24 10:53:01 +0800
committermax <max@FreeBSD.org>1998-06-24 10:53:01 +0800
commit68b5cefb392f4a04d963ffe3069d65f08cf3fac2 (patch)
tree710b4062a97a654bb12bf1c048100cbe858a288b /japanese/platex-sjis/Makefile
parent6eab96ccb2325ab39be1eb71373c36832276db0a (diff)
downloadfreebsd-ports-gnome-68b5cefb392f4a04d963ffe3069d65f08cf3fac2.tar.gz
freebsd-ports-gnome-68b5cefb392f4a04d963ffe3069d65f08cf3fac2.tar.zst
freebsd-ports-gnome-68b5cefb392f4a04d963ffe3069d65f08cf3fac2.zip
Integrate official patches released in past a few months.
Diffstat (limited to 'japanese/platex-sjis/Makefile')
-rw-r--r--japanese/platex-sjis/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/japanese/platex-sjis/Makefile b/japanese/platex-sjis/Makefile
index ac66d36c5367..2db1acdb32e0 100644
--- a/japanese/platex-sjis/Makefile
+++ b/japanese/platex-sjis/Makefile
@@ -3,27 +3,41 @@
# Date created: 05 Oct 1997
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.5 1997/11/22 01:38:52 asami Exp $
+# $Id: Makefile,v 1.6 1998/02/22 21:55:27 max Exp $
#
DISTNAME= pl19980217s
PKGNAME= ja-platex2e-sjis-1998.02.17.0
CATEGORIES= japanese print
MASTER_SITES= ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/platex/1998-02-17/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pl980227.patch.gz.txt pl980323.patch.gz.txt \
+ pl980409.patch.gz.txt pl980413.patch.gz.txt
MAINTAINER= max@FreeBSD.ORG
BUILD_DEPENDS= ptex:${PORTSDIR}/japanese/ptex-sjis \
- platex-common:${PORTSDIR}/japanese/platex-common
+ platex-common:${PORTSDIR}/japanese/platex-common \
+ nkf:${PORTSDIR}/japanese/nkf
RUN_DEPENDS= ptex:${PORTSDIR}/japanese/ptex-sjis \
platex-common:${PORTSDIR}/japanese/platex-common
MANUAL_PACKAGE_BUILD= incompatible with other versions of ptex-*
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/19980217
DIST_SUBDIR= platex2e
TEXMF= ${PREFIX}/share/texmf
+do-patch:
+.for f in 0227 0323 0413
+ @/usr/bin/uudecode -p ${DISTDIR}/${DIST_SUBDIR}/pl98${f}.patch.gz.txt \
+ | ${GZCAT} | nkf -s | ${PATCH} ${PATCH_DIST_ARGS}
+.endfor
+ @/usr/bin/uudecode -p ${DISTDIR}/${DIST_SUBDIR}/pl980409.patch.gz.txt \
+ | ${GZCAT} | nkf -s | ${SED} 3,33d | ${PATCH} ${PATCH_DIST_ARGS}
+ @${RM} -f ${WRKSRC}/*.orig
+
do-build:
@(cd ${WRKSRC}; ptex -ini plcore.ins; ptex -ini platex.ltx)