aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/sj3-server/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-09 15:08:07 +0800
committeredwin <edwin@FreeBSD.org>2007-09-09 15:08:07 +0800
commita4cea2257ccf05664ea092ee9d3d474e4cec3c3b (patch)
tree3d03a5fd710408681bd7af9a4e5fb7c93ac78617 /japanese/sj3-server/Makefile
parent8a39951a5139be79bc1a8ed49088e99b23203a59 (diff)
downloadfreebsd-ports-gnome-a4cea2257ccf05664ea092ee9d3d474e4cec3c3b.tar.gz
freebsd-ports-gnome-a4cea2257ccf05664ea092ee9d3d474e4cec3c3b.tar.zst
freebsd-ports-gnome-a4cea2257ccf05664ea092ee9d3d474e4cec3c3b.zip
[patch] japanese/sj3 is broken
There are several problems with japanese/sj3 port. 1. Original MASTER_SITES don't seem to work any longer. 2. With the current patchset it builds okay, but it is said that it does not work correctly. 3. It does not build under 7-CURRENT (i.e. with gcc4.2). PR: ports/113572 Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp> Approved by: maintainer timeout
Diffstat (limited to 'japanese/sj3-server/Makefile')
-rw-r--r--japanese/sj3-server/Makefile35
1 files changed, 18 insertions, 17 deletions
diff --git a/japanese/sj3-server/Makefile b/japanese/sj3-server/Makefile
index 19ab14977f5b..9bc58c4e16f2 100644
--- a/japanese/sj3-server/Makefile
+++ b/japanese/sj3-server/Makefile
@@ -7,41 +7,42 @@
PORTNAME= sj3
PORTVERSION= 2.0.1.20
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sony.co.jp/pub/unsupported/src/ \
ftp://ftp.cs.titech.ac.jp/pub/japanese/sj3/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= nork
-PATCH_SITES= http://oikumene.que.ne.jp/misc/
-PATCHFILES= ${PORTNAME}-patches-20040916.bz2
+PATCH_SITES= http://quasiquote.org/files/
+PATCHFILES= ${PORTNAME}-qq-2.0.1.21.diff.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= hiroo+freebsd@oikumene.gcd.org
COMMENT= A Japanese input method
-BUILD_DEPENDS= xmkmf:${X_IMAKE_PORT}
+USE_RC_SUBR= sj3.sh
+USE_IMAKE= yes
MAN1= sj3.1 sj3dic.1 sj3mkdic.1 sj3serv.1
MANLANG= ja
+MANCOMPRESSED= no
+PORTDOCS= Nihongo.ps.Z hinsi.ms makedict.ms sj3lib.ms sj3serv.ms
-STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/sj3.sh
-
-# This port requires xmkmf but installs in /usr/local
-#
# NOTE : You must not use 'xmkmf -a', because the running 'make depend' caused a error.
.include <bsd.port.pre.mk>
+pre-configure:
+ ${REINPLACE_CMD} -e "\#^SJ3TOP#s#=.*#= ${PREFIX}#" \
+ -e "\#^SJ3DICTDIR#s#=.*#= \\$$\(SJ3LIBDIR)/sj3/dict#" \
+ -e "\#^SJ3VARRUNDIR#s#=.*#= ${DESTDIR}\\$$\(VARDIR)/run/sj3#" \
+ ${WRKSRC}/sj3.tmpl
+
do-configure:
- ( cd $(WRKSRC) ; xmkmf ; make Makefiles )
-
-post-install:
- if [ ! -f ${STARTUP_SCRIPT} ]; then \
- ${ECHO_MSG} "Installing ${STARTUP_SCRIPT} startup file."; \
- ${INSTALL_SCRIPT} ${FILESDIR}/sj3.sh.in ${STARTUP_SCRIPT}; \
- fi
- ${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ( cd $(WRKSRC) ; ${XMKMF} ; make Makefiles )
+
+pre-install:
+ @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
.include <bsd.port.post.mk>