aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/tcl76/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-03-11 19:02:41 +0800
committerasami <asami@FreeBSD.org>1997-03-11 19:02:41 +0800
commit0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6 (patch)
treef42d1b6403fa0fe747a1f8338aeb6cec41c2ee72 /japanese/tcl76/Makefile
parent9e8e06034eb51565d47a3668b2dac1fb404721df (diff)
downloadfreebsd-ports-gnome-0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6.tar.gz
freebsd-ports-gnome-0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6.tar.zst
freebsd-ports-gnome-0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6.zip
Bugfix to set RANLIB correctly. Also set VERSION in port Makefile.
Closes PR ports/2937. Submitted by: Taguchi Takeshi <taguchi@tohoku.iij.ad.jp>
Diffstat (limited to 'japanese/tcl76/Makefile')
-rw-r--r--japanese/tcl76/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/japanese/tcl76/Makefile b/japanese/tcl76/Makefile
index 8c6b83edc76b..6a31ffaa10f8 100644
--- a/japanese/tcl76/Makefile
+++ b/japanese/tcl76/Makefile
@@ -1,9 +1,9 @@
# New ports collection makefile for: tcl7.6jp
# Version required: 7.6p2jp
-# Date created:
+# Date created: 11 March 1997
# Whom: taguchi@tohoku.iij.ad.jp
#
-# $Id: Makefile,v 1.1.1.1 1997/03/02 13:01:24 asami Exp $
+# $Id: Makefile,v 1.2 1997/03/05 23:13:23 asami Exp $
#
DISTNAME= tcl7.6p2
@@ -21,6 +21,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
+VERSION= 7.6jp
+
.if defined(PATCH_DEBUG)
PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} -E ${PATCH_DIST_STRIP}
.else
@@ -35,11 +37,11 @@ post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
pre-build:
- cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} && rm *.o
+ cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} && rm *.o
pre-install:
- ${MKDIR} ${PREFIX}/lib/tcl7.6jp
- cd ${WRKSRC} && ${MAKE} -f Makefile.lib install PREFIX=${PREFIX}
+ ${MKDIR} ${PREFIX}/lib/tcl${VERSION}
+ cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} install
post-install:
${LDCONFIG} -m ${PREFIX}/lib