aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/tcl76
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /japanese/tcl76
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'japanese/tcl76')
-rw-r--r--japanese/tcl76/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/japanese/tcl76/Makefile b/japanese/tcl76/Makefile
index 423689c01767..39741beb46d7 100644
--- a/japanese/tcl76/Makefile
+++ b/japanese/tcl76/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 March 1997
# Whom: taguchi@tohoku.iij.ad.jp
#
-# $Id: Makefile,v 1.6 1998/09/26 12:45:10 kuriyama Exp $
+# $Id: Makefile,v 1.7 1998/09/28 09:53:08 asami Exp $
#
DISTNAME= tcl7.6p2
@@ -29,6 +29,8 @@ PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} -E ${PATCH_DIST_STRIP}
PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} --forward --quiet -E ${PATCH_DIST_STRIP}
.endif
+.include <bsd.port.pre.mk>
+
post-extract:
@${MV} ${WRKDIR}/tcl7.6 ${WRKDIR}/${DISTNAME}
@@ -45,9 +47,9 @@ pre-install:
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libtcl76jp.so.1.0 ${PREFIX}/lib/libtcl76jp.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libtcl76jp.so.1.0 ${PREFIX}/lib/libtcl76jp.so
+.endif
test:
cd ${WRKSRC} && ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} test
@@ -55,4 +57,4 @@ test:
install-man:
cd ${WRKSRC} && ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} install-man
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>