aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/tcl80
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /japanese/tcl80
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'japanese/tcl80')
-rw-r--r--japanese/tcl80/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/japanese/tcl80/Makefile b/japanese/tcl80/Makefile
index 756e36dce8d0..83912efe30fb 100644
--- a/japanese/tcl80/Makefile
+++ b/japanese/tcl80/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 Jan 1998
# Whom: taguchi@tohoku.iij.ad.jp
#
-# $Id: Makefile,v 1.5 1998/09/27 11:17:06 kuriyama Exp $
+# $Id: Makefile,v 1.6 1998/09/28 10:23:58 asami Exp $
#
DISTNAME= tcl8.0.3
@@ -28,6 +28,8 @@ GNU_CONFIGURE= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS= --enable-shared
+.include <bsd.port.pre.mk>
+
.if !defined(NOPORTDOCS)
post-patch:
@${CP} ${FILESDIR}/README.FreeBSD.in ${TOPDIR}/README.FreeBSD.JP.in
@@ -47,9 +49,9 @@ post-install:
)
.endif
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libtcl80jp.so.1.2 ${PREFIX}/lib/libtcl80jp.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libtcl80jp.so.1.2 ${PREFIX}/lib/libtcl80jp.so
+.endif
@${CAT} ${PKGDIR}/MESSAGE
test:
@@ -58,4 +60,4 @@ test:
install-man:
cd ${WRKSRC} && ${SETENV} PORTOBJFORMAT=${PORTOBJFORMAT} ${MAKE} install-man
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>