aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/tk42
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-03-11 19:02:41 +0800
committerasami <asami@FreeBSD.org>1997-03-11 19:02:41 +0800
commit0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6 (patch)
treef42d1b6403fa0fe747a1f8338aeb6cec41c2ee72 /japanese/tk42
parent9e8e06034eb51565d47a3668b2dac1fb404721df (diff)
downloadfreebsd-ports-gnome-0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6.tar.gz
freebsd-ports-gnome-0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6.tar.zst
freebsd-ports-gnome-0fa5e07e41906b9d5ac91b22a00ed02a0ce7c8b6.zip
Bugfix to set RANLIB correctly. Also set VERSION in port Makefile.
Closes PR ports/2937. Submitted by: Taguchi Takeshi <taguchi@tohoku.iij.ad.jp>
Diffstat (limited to 'japanese/tk42')
-rw-r--r--japanese/tk42/Makefile6
-rw-r--r--japanese/tk42/files/Makefile.lib1
2 files changed, 3 insertions, 4 deletions
diff --git a/japanese/tk42/Makefile b/japanese/tk42/Makefile
index 66656896d7a3..00257ab10544 100644
--- a/japanese/tk42/Makefile
+++ b/japanese/tk42/Makefile
@@ -3,7 +3,7 @@
# Date created:
# Whom: taguchi@tohoku.iij.ad.jp
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/03/02 13:02:06 asami Exp $
#
DISTNAME= tk4.2p2
@@ -41,13 +41,13 @@ post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
pre-build:
- cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} && rm -f *.o
+ cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} && rm -f *.o
pre-install:
${MKDIR} ${PREFIX}/lib/tk${VERSION}
post-install:
- cd ${WRKSRC} && ${MAKE} -f Makefile.lib install PREFIX=${PREFIX}
+ cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} VERSION=${VERSION} install
${LDCONFIG} -m ${PREFIX}/lib
@echo "**********"
@echo "IMPORTANT:"
diff --git a/japanese/tk42/files/Makefile.lib b/japanese/tk42/files/Makefile.lib
index b2be2e63b17a..cfba95ed3e2d 100644
--- a/japanese/tk42/files/Makefile.lib
+++ b/japanese/tk42/files/Makefile.lib
@@ -1,4 +1,3 @@
-VERSION= 4.2jp
NOPROFILE= yes
LIB= tk${VERSION}
TK_LIBRARY= ${PREFIX}/lib/tk${VERSION}