aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/trac
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-26 08:33:54 +0800
committerjgh <jgh@FreeBSD.org>2013-05-26 08:33:54 +0800
commitfcb5ff048f70ea102fd14739e7dd9415619cebaa (patch)
tree8e9ec7d8d59a4cf16133c2b4620f0454a709c459 /japanese/trac
parent4251ddb17fff5064650e0e159dd592f22fbe284e (diff)
downloadfreebsd-ports-gnome-fcb5ff048f70ea102fd14739e7dd9415619cebaa.tar.gz
freebsd-ports-gnome-fcb5ff048f70ea102fd14739e7dd9415619cebaa.tar.zst
freebsd-ports-gnome-fcb5ff048f70ea102fd14739e7dd9415619cebaa.zip
- adoption of optionsNG framework
- trim COMMENTS and historical headers Approved by: portmgr (bapt)
Diffstat (limited to 'japanese/trac')
-rw-r--r--japanese/trac/Makefile33
1 files changed, 18 insertions, 15 deletions
diff --git a/japanese/trac/Makefile b/japanese/trac/Makefile
index fc8bb7559bc9..6d05ca0669dd 100644
--- a/japanese/trac/Makefile
+++ b/japanese/trac/Makefile
@@ -10,19 +10,22 @@ MASTER_SITE_SUBDIR= kuriyama
DISTNAME= Trac-${PORTVERSION}.ja2
MAINTAINER= kuriyama@FreeBSD.org
-COMMENT= An enhanced wiki and issue tracking system for software projects
+COMMENT= Enhanced wiki and issue tracking system for software projects
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:${PORTSDIR}/textproc/py-genshi \
${PYTHON_PKGNAMEPREFIX}Babel>=0.9:${PORTSDIR}/devel/py-babel
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:${PORTSDIR}/textproc/py-genshi \
${PYTHON_PKGNAMEPREFIX}Babel>=0.9:${PORTSDIR}/devel/py-babel
-OPTIONS= SILVERCITY "Use Silvercity for syntax highlighting" On \
- DOCUTILS "Allow additional text markup" On \
- PYGMENTS "Use generic syntax highlighter" On \
- TZ "Process Time Zones" On \
- PGSQL "Use PostgreSQL instead of SQLite3" Off \
- SUBVERSION "Support for subversion RCS" On
+OPTIONS_DEFINE= SILVERCITY DOCUTILS PYGMENTS TZ PGSQL SVN
+SILVERCITY_DESC= Use Silvercity for syntax highlighting
+DOCUTILS_DESC= Allow additional text markup
+PYGMENTS_DESC= Use generic syntax highlighter
+TZ_DESC= Process Time Zones
+SVN_DESC= Support for subversion RCS
+
+OPTIONS_DEFAULT= SILVERCITY DOCUTILS PYGMENTS TZ SUBVERSION
+
CONFLICTS= trac-0.*
USE_ZIP= yes
@@ -62,32 +65,32 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SILVERCITY)
+.if ${PORT_OPTIONS:MSILVERCITY}
RUN_DEPENDS+= ${LOCALBASE}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
.endif
-.if defined(WITH_DOCUTILS)
+.if ${PORT_OPTIONS:MDOCUTILS}
RUN_DEPENDS+= ${LOCALBASE}/bin/rst2html:${PORTSDIR}/textproc/py-docutils
.endif
-.if defined(WITH_PYGMENTS)
+.if ${PORT_OPTIONS:MPYGMENTS}
RUN_DEPENDS+= ${LOCALBASE}/bin/pygmentize:${PORTSDIR}/textproc/py-pygments
.endif
-.if defined(WITH_TZ)
+.if ${PORT_OPTIONS:MTZ}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
.else
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
-.if !defined(WITHOUT_SUBVERSION)
+.if ${PORT_OPTIONS:MSVN}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/svn/__init__.py:${PORTSDIR}/devel/py-subversion
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>