aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/uim/files
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2003-12-11 18:02:59 +0800
committernobutaka <nobutaka@FreeBSD.org>2003-12-11 18:02:59 +0800
commit19a5174a62ab0506e1024a25321ac8011ff5b369 (patch)
treeb940330528d00070d30785d274e1ed6dfab355d3 /japanese/uim/files
parent85eccd5d213a1c7faaec7fd067c9646dc58d21dd (diff)
downloadfreebsd-ports-gnome-19a5174a62ab0506e1024a25321ac8011ff5b369.tar.gz
freebsd-ports-gnome-19a5174a62ab0506e1024a25321ac8011ff5b369.tar.zst
freebsd-ports-gnome-19a5174a62ab0506e1024a25321ac8011ff5b369.zip
Update to 0.2.0.
Diffstat (limited to 'japanese/uim/files')
-rw-r--r--japanese/uim/files/patch-Makefile.in11
-rw-r--r--japanese/uim/files/patch-helper:helper-applet.c23
-rw-r--r--japanese/uim/files/patch-helper:helper-candwin-gtk.c15
-rw-r--r--japanese/uim/files/patch-xim:Makefile.in11
4 files changed, 22 insertions, 38 deletions
diff --git a/japanese/uim/files/patch-Makefile.in b/japanese/uim/files/patch-Makefile.in
new file mode 100644
index 000000000000..6ec0c3dc7c7c
--- /dev/null
+++ b/japanese/uim/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Dec 10 23:28:20 2003
++++ Makefile.in Wed Dec 10 23:29:10 2003
+@@ -198,7 +198,7 @@
+ @GTK2_TRUE@gtk_entry_CFLAGS = @GTK2_CFLAGS@
+
+ uim_agent_SOURCES = agent.c
+-uim_agent_LDADD = uim/libuim.la
++uim_agent_LDADD = uim/libuim.la -liconv
+
+ ACLOCAL_AMFLAGS = -I m4
+ subdir = .
diff --git a/japanese/uim/files/patch-helper:helper-applet.c b/japanese/uim/files/patch-helper:helper-applet.c
deleted file mode 100644
index 9a872a80a11a..000000000000
--- a/japanese/uim/files/patch-helper:helper-applet.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- helper/helper-applet.c.orig Tue Oct 14 00:07:31 2003
-+++ helper/helper-applet.c Tue Oct 14 00:24:43 2003
-@@ -134,6 +134,7 @@
- gchar **tmp2 = NULL;
- gchar *charset = NULL;
- GString *path = g_string_new("");
-+ GtkItemFactoryEntry entry;
-
- tmp2 = g_strsplit(tmp[1], "=", 0);
-
-@@ -176,7 +177,11 @@
- gtk_widget_show(button);
- } else if(strcmp("leaf", tmp2[0]) == 0) {
- g_string_printf(path, "/%s", tmp2[2]);
-- GtkItemFactoryEntry entry = {path->str, NULL, G_CALLBACK(activate_event), 0, ""};
-+ entry.path = path->str;
-+ entry.accelerator = NULL;
-+ entry.callback = G_CALLBACK(activate_event);
-+ entry.callback_action = 0;
-+ entry.item_type = "";
- gtk_item_factory_create_item ( mode_item_fact, &entry, tmp2[4], 1);
-
- }
diff --git a/japanese/uim/files/patch-helper:helper-candwin-gtk.c b/japanese/uim/files/patch-helper:helper-candwin-gtk.c
deleted file mode 100644
index 9d85f729dab2..000000000000
--- a/japanese/uim/files/patch-helper:helper-candwin-gtk.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- helper/helper-candwin-gtk.c.orig Sun Nov 9 02:26:21 2003
-+++ helper/helper-candwin-gtk.c Sun Nov 9 02:27:22 2003
-@@ -160,10 +160,11 @@
- {
- int index;
- char idx[20];
-+ GtkTreePath* path;
- sscanf(str[1],"%d",&index);
- cwin.candidate_index = index;
-
-- GtkTreePath* path = gtk_tree_path_new_from_indices(index, -1);
-+ path = gtk_tree_path_new_from_indices(index, -1);
- gtk_tree_view_set_cursor(GTK_TREE_VIEW(m_view),
- path, NULL, FALSE);
- gtk_tree_view_scroll_to_cell(GTK_TREE_VIEW(m_view),
diff --git a/japanese/uim/files/patch-xim:Makefile.in b/japanese/uim/files/patch-xim:Makefile.in
new file mode 100644
index 000000000000..74878dad9beb
--- /dev/null
+++ b/japanese/uim/files/patch-xim:Makefile.in
@@ -0,0 +1,11 @@
+--- xim/Makefile.in.orig Wed Dec 10 23:36:10 2003
++++ xim/Makefile.in Wed Dec 10 23:37:25 2003
+@@ -182,7 +182,7 @@
+
+ bin_PROGRAMS = uim-xim
+ uim_xim_LDFLAGS = -L/usr/lib -L/usr/X11R6/lib
+-uim_xim_LDADD = -lXext -lX11 ../uim/libuim.la
++uim_xim_LDADD = -lXext -lX11 ../uim/libuim.la -liconv
+
+ uim_xim_SOURCES = \
+ main.cpp convdisp.cpp \