aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/vftool/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commitaa52cd921c82a10ec33065084fe0edb5cf8bebbc (patch)
treeb70284a297d2e3c06462e3a3a86166c4371477f9 /japanese/vftool/Makefile
parentdd1603cad7e60d10dd91a2f1f918e24ed859ed24 (diff)
downloadfreebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.gz
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.zst
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'japanese/vftool/Makefile')
-rw-r--r--japanese/vftool/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/japanese/vftool/Makefile b/japanese/vftool/Makefile
index 96561af4f5a1..1ad05c23cce8 100644
--- a/japanese/vftool/Makefile
+++ b/japanese/vftool/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 September 1997
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
-# $Id: Makefile,v 1.5 1998/08/09 00:58:46 steve Exp $
+# $Id: Makefile,v 1.6 1998/08/24 00:39:46 steve Exp $
#
DISTNAME= vftool-1.2
@@ -35,8 +35,10 @@ TARGETDIRS= vf-n2a vf-a2n vf-a2bk vf-p2pn
post-extract:
(cd ${WRKDIR}; \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/plib13-euc.tar.gz \
+ ${EXTRACT_AFTER_ARGS} \
share/texmf/fonts/tfm/ptex; \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/jtex-1.52.tar.gz \
+ ${EXTRACT_AFTER_ARGS} \
jtex-1.52/JTeXfonts/dnpfonts/mincho/tfm \
jtex-1.52/JTeXfonts/dnpfonts/gothic/tfm; \
)