aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/wordpress/Makefile
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-10-16 13:24:10 +0800
committertota <tota@FreeBSD.org>2011-10-16 13:24:10 +0800
commit7fd3800e15d8c2b66d0dc8a2b903aaf417606970 (patch)
tree9bd82012127e0dbe0365c1377795445da7c5eeec /japanese/wordpress/Makefile
parent84b7917f811f6af331ec590644adf0b613b8dbb0 (diff)
downloadfreebsd-ports-gnome-7fd3800e15d8c2b66d0dc8a2b903aaf417606970.tar.gz
freebsd-ports-gnome-7fd3800e15d8c2b66d0dc8a2b903aaf417606970.tar.zst
freebsd-ports-gnome-7fd3800e15d8c2b66d0dc8a2b903aaf417606970.zip
- Add a new port: japanese/wordpress
WordPress is a state-of-the-art semantic personal publishing platform with a focus on aesthetics, web standards, and usability. More simply, Wordpress is what you use when you want to work with your blogging software, not fight it. WWW: http://ja.wordpress.org/ PR: ports/160172 Submitted by: Takefu <takefu_AT_airport_DOT_fm>
Diffstat (limited to 'japanese/wordpress/Makefile')
-rw-r--r--japanese/wordpress/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/japanese/wordpress/Makefile b/japanese/wordpress/Makefile
new file mode 100644
index 000000000000..0853542b5817
--- /dev/null
+++ b/japanese/wordpress/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: wordpress
+# Date created: 2011-09-20
+# Whom: Takefu
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordpress
+PORTVERSION= 3.2.1
+CATEGORIES= japanese www
+MASTER_SITES= http://ja.wordpress.org/
+PKGNAMESUFFIX= -ja
+DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}
+
+MAINTAINER= takefu@airport.fm
+COMMENT= A state-of-the-art semantic personal publishing platform
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+CONFLICTS_INSTALL= wordpress-3.* de-wordpress-de-3.*
+
+NO_BUILD= yes
+USE_PHP= gd mysql pcre tokenizer xml zip
+WANT_PHP_WEB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST= ${WRKDIR}/pkg-plist
+PORTDOCS= license.txt readme.html
+
+pre-everything::
+ @${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
+ @${ECHO_CMD} ""
+ @sleep 1
+
+pre-install:
+ cd ${WRKSRC}/ && \
+ (${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|'; \
+ ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|') > ${PLIST}
+ if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
+ ${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
+
+do-install:
+ ${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${WWWDIR}/
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>