aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/xchat
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-11-07 03:39:43 +0800
committerknu <knu@FreeBSD.org>2000-11-07 03:39:43 +0800
commite3be7dd961c3c713d94d976070a9f3cc768f23f0 (patch)
tree42d2dfd5c9ed4c4c5fb8429acdf065af510080a4 /japanese/xchat
parent378ff67b64d18f8799658f96944ceb7261eda804 (diff)
downloadfreebsd-ports-gnome-e3be7dd961c3c713d94d976070a9f3cc768f23f0.tar.gz
freebsd-ports-gnome-e3be7dd961c3c713d94d976070a9f3cc768f23f0.tar.zst
freebsd-ports-gnome-e3be7dd961c3c713d94d976070a9f3cc768f23f0.zip
Fix japanese/xchat which had been broken by the last two commits on
irc/xchat. As japanese/xchat "built" without a problem, I didn't notice it was "broken"... In reality, the configure script failed to detect the iconv library because of the removal of CPPFLAGS and LIBS in CONFIGURE_ENV, therefore the built binary lacked Japanese support. (i.e. the ja-xchat package included in 4.2-RELEASE will be broken) To avoid this kind of sad accidents in future, add a note to irc/xchat that it has a slave port and one should be careful not to overwrite variables or targets.
Diffstat (limited to 'japanese/xchat')
-rw-r--r--japanese/xchat/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/japanese/xchat/Makefile b/japanese/xchat/Makefile
index c27b9ab0a0cf..59a09e93289b 100644
--- a/japanese/xchat/Makefile
+++ b/japanese/xchat/Makefile
@@ -7,6 +7,7 @@
MASTERDIR= ${.CURDIR}/../../irc/xchat
+PORTREVISION= 1
CATEGORIES= japanese
PATCH_SITES= http://northeye.org/~takuo/xchat-ja/
PATCHFILES= ${PORTNAME}-${PORTVERSION}.ja.3.diff.gz
@@ -18,6 +19,8 @@ LIB_DEPENDS= iconv.1:${PORTSDIR}/converters/iconv
MD5_FILE= ${.CURDIR}/distinfo
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-japanese-conv # --enable-ipv6
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"