aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/xjman-3
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2001-08-06 22:07:47 +0800
committersada <sada@FreeBSD.org>2001-08-06 22:07:47 +0800
commitceb2ae489371064601e941e47da59655d3fbb038 (patch)
tree66ab21a4c10e700a1292c610591e12650b4d9e28 /japanese/xjman-3
parentb817ef60bbaf5c18198ef797306dffc56f2af2e6 (diff)
downloadfreebsd-ports-gnome-ceb2ae489371064601e941e47da59655d3fbb038.tar.gz
freebsd-ports-gnome-ceb2ae489371064601e941e47da59655d3fbb038.tar.zst
freebsd-ports-gnome-ceb2ae489371064601e941e47da59655d3fbb038.zip
Cope with update of bsd.man.mk .
Submitted by: sf [FreeBSD-users-jp 63159] Reported by: Yasuhito KAMINAGA <kaminaga@nat.gunma-ct.ac.jp>
Diffstat (limited to 'japanese/xjman-3')
-rw-r--r--japanese/xjman-3/Makefile7
-rw-r--r--japanese/xjman-3/scripts/configure2
2 files changed, 7 insertions, 2 deletions
diff --git a/japanese/xjman-3/Makefile b/japanese/xjman-3/Makefile
index 0bdeee0e8c71..a7788587b8cf 100644
--- a/japanese/xjman-3/Makefile
+++ b/japanese/xjman-3/Makefile
@@ -27,6 +27,11 @@ post-extract:
.for i in Makefile Makefile.inc
@${CP} ${FILESDIR}/$i ${WRKSRC}
.endfor
+.for sec in ${MANSECS}
+ (cd ${WRKSRC}/man${sec}; \
+ for f in *.${sec}x; do ${CP} $$f $${f%x}; done; \
+ ${PERL} -pi -e 's/^(\.so .*)x$$/$$1/' *.${sec})
+.endfor
post-build:
@${RM} -f ${PLIST}
@@ -34,7 +39,7 @@ post-build:
if [ -d ${WRKSRC}/man$${sec} ]; then \
cd ${WRKSRC}/man$${sec}; \
list=`${MAKE} pages-list`; \
- set `${ECHO} $$list " "|${SED} 's/\.\([0-9]\)x /.\1x \1 /g'`; \
+ set `${ECHO} $$list " "|${SED} 's/\.\([0-9]\) /.\1 \1 /g'`; \
while : ; do \
case $$# in \
0) break;; \
diff --git a/japanese/xjman-3/scripts/configure b/japanese/xjman-3/scripts/configure
index eb66aa645232..8da3fb55d313 100644
--- a/japanese/xjman-3/scripts/configure
+++ b/japanese/xjman-3/scripts/configure
@@ -11,7 +11,7 @@ for $sec (@MANSECS) {
@manpages = ();
@mlinks = ();
- for $manpage (<*.${sec}x>) {
+ for $manpage (<*.${sec}>) {
open(F, $manpage) || die "cannot open $manpage: $!\n";
$_ = <F>;
chop;