aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2005-06-07 00:15:50 +0800
committernobutaka <nobutaka@FreeBSD.org>2005-06-07 00:15:50 +0800
commit859553b97a6127e45221e0ed1444fd51b8ff1b44 (patch)
treef75dba9ebef3d678e0210b892ee7d7ca04bee97e /japanese
parent8ac956bcfe939eba614f2d25ff448867d37c1425 (diff)
downloadfreebsd-ports-gnome-859553b97a6127e45221e0ed1444fd51b8ff1b44.tar.gz
freebsd-ports-gnome-859553b97a6127e45221e0ed1444fd51b8ff1b44.tar.zst
freebsd-ports-gnome-859553b97a6127e45221e0ed1444fd51b8ff1b44.zip
Fix build error on 4-stable.
PR: ports/81511 Submitted by: Ports Fury
Diffstat (limited to 'japanese')
-rw-r--r--japanese/kasumi/Makefile15
-rw-r--r--japanese/kasumi/files/patch-KasumiException.hxx11
2 files changed, 17 insertions, 9 deletions
diff --git a/japanese/kasumi/Makefile b/japanese/kasumi/Makefile
index 4b2e1a338854..0e63742eb0fc 100644
--- a/japanese/kasumi/Makefile
+++ b/japanese/kasumi/Makefile
@@ -17,9 +17,12 @@ COMMENT= A dictionary management tool for anthy
USE_X_PREFIX= yes
USE_GNOME= gnomehier gtk20
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
@@ -29,10 +32,4 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/kasumi/files/patch-KasumiException.hxx b/japanese/kasumi/files/patch-KasumiException.hxx
new file mode 100644
index 000000000000..f4497c682f16
--- /dev/null
+++ b/japanese/kasumi/files/patch-KasumiException.hxx
@@ -0,0 +1,11 @@
+--- KasumiException.hxx.orig Fri Jan 7 23:18:09 2005
++++ KasumiException.hxx Sun May 22 19:58:45 2005
+@@ -5,6 +5,8 @@
+ #include "config.h"
+ #endif
+
++#include <string>
++
+ using namespace std;
+
+ class KasumiDicExaminationException{