aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-03 14:37:44 +0800
committeredwin <edwin@FreeBSD.org>2005-11-03 14:37:44 +0800
commitef73f07bfb3d5d5d904dbb3705de3ffc114d3319 (patch)
tree96ea2dc323110b6e2e76b5fad5af1455e7dda26e /japanese
parent3407608b4310d2fc97f41756f0cd22605275b453 (diff)
downloadfreebsd-ports-gnome-ef73f07bfb3d5d5d904dbb3705de3ffc114d3319.tar.gz
freebsd-ports-gnome-ef73f07bfb3d5d5d904dbb3705de3ffc114d3319.tar.zst
freebsd-ports-gnome-ef73f07bfb3d5d5d904dbb3705de3ffc114d3319.zip
Fix pkg-plist by carefully deleting unnecessasry lines.
Taken examples from lang/perl5
Diffstat (limited to 'japanese')
-rw-r--r--japanese/perl5/Makefile6
-rw-r--r--japanese/perl5/pkg-plist121
2 files changed, 77 insertions, 50 deletions
diff --git a/japanese/perl5/Makefile b/japanese/perl5/Makefile
index 2442ccb832ae..db30f1c77b1a 100644
--- a/japanese/perl5/Makefile
+++ b/japanese/perl5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${JPERL_VER}.${JPERL_VER_PL}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese perl5
MASTER_SITES= ftp://ftp.cpan.org/CPAN/src/5.0/ \
ftp://ftp.funet.fi/pub/languages/perl/CPAN/src/5.0/ \
@@ -40,10 +40,6 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= Pattern Extraction and Recognition Language + Japanese patches
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
.include <bsd.port.pre.mk>
HAS_CONFIGURE= yes
diff --git a/japanese/perl5/pkg-plist b/japanese/perl5/pkg-plist
index 02379ad4300b..80700c5730a3 100644
--- a/japanese/perl5/pkg-plist
+++ b/japanese/perl5/pkg-plist
@@ -528,56 +528,87 @@ lib/perl5/%%JPERL_VERSION%%/termcap.pl
lib/perl5/%%JPERL_VERSION%%/timelocal.pl
lib/perl5/%%JPERL_VERSION%%/validate.pl
lib/perl5/%%JPERL_VERSION%%/vars.pm
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/B 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/CGI 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/CPAN 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Class 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Data 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Devel 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/ExtUtils 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/File/Spec 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/File 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Getopt 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/I18N 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/IPC 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Math 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Net 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Pod 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Search 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Sys 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Term 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Test 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Text 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Tie 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Time 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/User 2>/dev/null || true
+@unexec find %D/lib/perl5/%%JPERL_VER%%/ -name '*.ph' -delete 2>/dev/null || true
+@unexec find %D/lib/perl5/site_perl/%%JPERL_VER%%/ -name '*.ph' -delete 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%JPERL_VER%%/i386-freebsd/sys 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%JPERL_VER%%/i386-freebsd/machine 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%JPERL_VER%%/i386-freebsd 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%JPERL_VER%% 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/pod 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/man/man3 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/man 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/sdbm 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/re 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/attrs 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/Socket 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/SDBM_File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/POSIX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/Opcode 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/NDBM_File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/IPC/SysV 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/IPC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/Fcntl 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/DynaLoader 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/Data/Dumper 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/Data 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/DB_File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto/B 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/auto 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/CORE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd/B 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/i386-freebsd 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/auto/Getopt/Long 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/auto/Getopt 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/auto 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/B 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/CORE 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/IO 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/B 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/DB_File 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Data/Dumper 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/DynaLoader 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Fcntl 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/User 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Time 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Tie 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Text 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Test 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Term 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Sys 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Search 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Pod 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/IPC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/I18N 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Getopt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/File/Spec 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/ExtUtils 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Devel 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Data 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/CPAN 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/CGI 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/B 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/sdbm 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/re 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/attrs 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Socket 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/SDBM_File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/POSIX 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Opcode 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/NDBM_File 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/IPC/SysV 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/IPC 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/NDBM_File 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Opcode 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/POSIX 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/SDBM_File 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Socket 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/attrs 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/re 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/sdbm 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Fcntl 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/DynaLoader 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Data/Dumper 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/DB_File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto/B 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/auto 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/IO 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/CORE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%%/B 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%% 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/%%PERL_ARCH%% 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/man/man3 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/man 2>/dev/null || true
-@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%%/pod 2>/dev/null || true
@unexec rmdir %D/lib/perl5/%%JPERL_VERSION%% 2>/dev/null || true
+@unexec rmdir %D/lib/perl5 2>/dev/null || true
+
+