aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-10-14 15:07:12 +0800
committersada <sada@FreeBSD.org>2002-10-14 15:07:12 +0800
commitfaa2fa08bd73a89e0aab0a827d147041bf94935f (patch)
tree18e73a702e4404da06295853a558f4ead6650be1 /japanese
parent7b56f301753719dbf3b632607d7573b4ab366d5c (diff)
downloadfreebsd-ports-gnome-faa2fa08bd73a89e0aab0a827d147041bf94935f.tar.gz
freebsd-ports-gnome-faa2fa08bd73a89e0aab0a827d147041bf94935f.tar.zst
freebsd-ports-gnome-faa2fa08bd73a89e0aab0a827d147041bf94935f.zip
Add new port: ja-mikachan-ttfonts.
This is handwritten TrueType font-set. See: http://mikachan-font.com Lha use was adviced by sf, thanks.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/mikachan-ttfonts/Makefile40
-rw-r--r--japanese/mikachan-ttfonts/distinfo1
-rw-r--r--japanese/mikachan-ttfonts/files/fonts.dir.mika5
-rw-r--r--japanese/mikachan-ttfonts/pkg-comment1
-rw-r--r--japanese/mikachan-ttfonts/pkg-deinstall11
-rw-r--r--japanese/mikachan-ttfonts/pkg-descr4
-rw-r--r--japanese/mikachan-ttfonts/pkg-install20
-rw-r--r--japanese/mikachan-ttfonts/pkg-plist2
9 files changed, 85 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index abd2a73c79b2..b304053e27a9 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -208,6 +208,7 @@
SUBDIR += migemo-emacs21
SUBDIR += migemo-xemacs-devel-mule
SUBDIR += migemo-xemacs21-mule
+ SUBDIR += mikachan-ttfonts
SUBDIR += mimekit
SUBDIR += ming
SUBDIR += mnews
diff --git a/japanese/mikachan-ttfonts/Makefile b/japanese/mikachan-ttfonts/Makefile
new file mode 100644
index 000000000000..6e6200f1a0f7
--- /dev/null
+++ b/japanese/mikachan-ttfonts/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: TrueTypeFont Mika-chan
+# Date created: 12 October 2002
+# Whom: sada
+# Based on: KANOU Hiroki's kochi-ttfonts
+#
+# $FreeBSD$
+#
+
+PORTNAME= mikachan-ttfonts
+PORTVERSION= 8.5
+CATEGORIES= japanese x11-fonts
+MASTER_SITES= http://members.tripod.co.jp/mikachan_font/
+DISTNAME= ver${PORTVERSION}
+EXTRACT_SUFX= .lzh
+
+MAINTAINER= sada@FreeBSD.org
+
+BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha
+
+RESTRICTED= "detailed condition is not clear"
+EXTRACT_CMD= lha
+EXTRACT_BEFORE_ARGS= pq
+EXTRACT_AFTER_ARGS= > ${WRKSRC}/mika.ttf
+DIST_SUBDIR= ${PORTNAME}
+USE_X_PREFIX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+MAKE_ENV= FONTSDIR=${FONTSDIR}
+PLIST_SUB= FONTSDIR=${FONTSDIR}
+
+FONTSDIR= lib/X11/fonts/TrueType
+
+do-install:
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ ${INSTALL_DATA} \
+ ${WRKDIR}/mika.ttf ${FILESDIR}/fonts.dir.mika \
+ ${PREFIX}/${FONTSDIR}
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/japanese/mikachan-ttfonts/distinfo b/japanese/mikachan-ttfonts/distinfo
new file mode 100644
index 000000000000..52617c57ac3c
--- /dev/null
+++ b/japanese/mikachan-ttfonts/distinfo
@@ -0,0 +1 @@
+MD5 (mikachan-ttfonts/ver8.5.lzh) = 8d9c233e1b29070bf22890dd65efa083
diff --git a/japanese/mikachan-ttfonts/files/fonts.dir.mika b/japanese/mikachan-ttfonts/files/fonts.dir.mika
new file mode 100644
index 000000000000..fc2d641a0b4f
--- /dev/null
+++ b/japanese/mikachan-ttfonts/files/fonts.dir.mika
@@ -0,0 +1,5 @@
+4
+bw=0.5:mika.ttf -misc-mikachan-medium-r-normal--0-0-0-0-c-0-iso8859-1
+bw=0.5:mika.ttf -misc-mikachan-medium-r-normal--0-0-0-0-c-0-jisx0201.1976-0
+mika.ttf -misc-mikachan-medium-r-normal--0-0-0-0-c-0-jisx0208.1983-0
+mika.ttf -misc-mikachan-medium-r-normal--0-0-0-0-p-0-iso8859-1
diff --git a/japanese/mikachan-ttfonts/pkg-comment b/japanese/mikachan-ttfonts/pkg-comment
new file mode 100644
index 000000000000..236be37fa69d
--- /dev/null
+++ b/japanese/mikachan-ttfonts/pkg-comment
@@ -0,0 +1 @@
+Handwritten Japanese TrueType fonts by Mika-chan
diff --git a/japanese/mikachan-ttfonts/pkg-deinstall b/japanese/mikachan-ttfonts/pkg-deinstall
new file mode 100644
index 000000000000..f1ade519c898
--- /dev/null
+++ b/japanese/mikachan-ttfonts/pkg-deinstall
@@ -0,0 +1,11 @@
+#!/bin/sh
+if [ "$2" != "DEINSTALL" ]; then
+ exit 0
+fi
+FONTDIR=${PKG_PREFIX}/lib/X11/fonts/TrueType
+cd ${FONTDIR}
+sed -e '/-mikachan-/d' fonts.dir > fonts.dir.tmp
+numfonts=$(echo $(cat fonts.dir.tmp | wc -l) - 1 | bc)
+echo ${numfonts} > fonts.dir
+sed -e 1d fonts.dir.tmp >> fonts.dir
+rm -f fonts.dir.tmp
diff --git a/japanese/mikachan-ttfonts/pkg-descr b/japanese/mikachan-ttfonts/pkg-descr
new file mode 100644
index 000000000000..f27253423251
--- /dev/null
+++ b/japanese/mikachan-ttfonts/pkg-descr
@@ -0,0 +1,4 @@
+Mika-chan wrote a full set of Japanese fonts by hand, scanned,
+then translated it to a TrueTypeFont package.
+
+WWW: http://mikachan-font.com/
diff --git a/japanese/mikachan-ttfonts/pkg-install b/japanese/mikachan-ttfonts/pkg-install
new file mode 100644
index 000000000000..b8a31fb1da6e
--- /dev/null
+++ b/japanese/mikachan-ttfonts/pkg-install
@@ -0,0 +1,20 @@
+#!/bin/sh
+FONTDIR=${PKG_PREFIX}/lib/X11/fonts/TrueType
+if [ "$2" = "PRE-INSTALL" ]; then
+ if [ ! -d ${FONTDIR} ]; then
+ echo "*********************************************************"
+ echo "Please add ${FONTDIR} to your font path"
+ echo "and load 'xtt' module in /etc/XF86Config."
+ echo "*********************************************************"
+ mkdir $FONTDIR
+ fi
+ exit 0
+fi
+cd ${FONTDIR}
+touch fonts.dir
+sed -e '/-mikachan-/d' fonts.dir > fonts.dir.tmp
+numfonts=$(echo $(cat fonts.dir.tmp fonts.dir.mika | wc -l) - 2 | bc)
+echo ${numfonts} > fonts.dir
+sed -e 1d fonts.dir.tmp >> fonts.dir
+sed -e 1d fonts.dir.mika >> fonts.dir
+rm -f fonts.dir.tmp fonts.alias.tmp
diff --git a/japanese/mikachan-ttfonts/pkg-plist b/japanese/mikachan-ttfonts/pkg-plist
new file mode 100644
index 000000000000..d609fc575935
--- /dev/null
+++ b/japanese/mikachan-ttfonts/pkg-plist
@@ -0,0 +1,2 @@
+%%FONTSDIR%%/fonts.dir.mika
+%%FONTSDIR%%/mika.ttf