aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authoryoichi <yoichi@FreeBSD.org>2002-04-06 00:02:16 +0800
committeryoichi <yoichi@FreeBSD.org>2002-04-06 00:02:16 +0800
commit11afca86d88f0965454d5c2334631a6ad0210765 (patch)
tree8e461bfd937868067747ea718ed710bcb304251f /japanese
parent5959e10633a3692ac119feb44d859370242f0776 (diff)
downloadfreebsd-ports-gnome-11afca86d88f0965454d5c2334631a6ad0210765.tar.gz
freebsd-ports-gnome-11afca86d88f0965454d5c2334631a6ad0210765.tar.zst
freebsd-ports-gnome-11afca86d88f0965454d5c2334631a6ad0210765.zip
Add ebview, a gtk based tool to access CD-ROM dictionaries.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/ebview-gtk2/Makefile34
-rw-r--r--japanese/ebview-gtk2/distinfo1
-rw-r--r--japanese/ebview-gtk2/pkg-comment1
-rw-r--r--japanese/ebview-gtk2/pkg-descr4
-rw-r--r--japanese/ebview-gtk2/pkg-plist5
-rw-r--r--japanese/ebview/Makefile34
-rw-r--r--japanese/ebview/distinfo1
-rw-r--r--japanese/ebview/pkg-comment1
-rw-r--r--japanese/ebview/pkg-descr4
-rw-r--r--japanese/ebview/pkg-plist5
11 files changed, 91 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index eeb122709c13..6e335c3fc606 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -57,6 +57,7 @@
SUBDIR += eb2
SUBDIR += ebd-fpw
SUBDIR += eblook
+ SUBDIR += ebview
SUBDIR += ebw3
SUBDIR += edict
SUBDIR += edict-fpw
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
new file mode 100644
index 000000000000..dcdb0423098d
--- /dev/null
+++ b/japanese/ebview-gtk2/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ebview
+# Date Created: 28 Jan 2002
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ebview
+PORTVERSION= 0.1.4
+CATEGORIES= japanese
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= yoichi@FreeBSD.org
+
+LIB_DEPENDS= eb.6:${PORTSDIR}/japanese/eb
+
+USE_GTK= yes
+USE_IMLIB= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_ARGS= SUBDIRS=src
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/locale/ja/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/po/ja.gmo ${PREFIX}/share/locale/ja/LC_MESSAGES/ebview.mo
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/ebview-gtk2/distinfo b/japanese/ebview-gtk2/distinfo
new file mode 100644
index 000000000000..e13c9a70f30d
--- /dev/null
+++ b/japanese/ebview-gtk2/distinfo
@@ -0,0 +1 @@
+MD5 (ebview-0.1.4.tar.gz) = d95ceca15303c1142c043849eff3efbe
diff --git a/japanese/ebview-gtk2/pkg-comment b/japanese/ebview-gtk2/pkg-comment
new file mode 100644
index 000000000000..32cf50dd9312
--- /dev/null
+++ b/japanese/ebview-gtk2/pkg-comment
@@ -0,0 +1 @@
+Electronic Book Viewer
diff --git a/japanese/ebview-gtk2/pkg-descr b/japanese/ebview-gtk2/pkg-descr
new file mode 100644
index 000000000000..2ff8a9ffa8b4
--- /dev/null
+++ b/japanese/ebview-gtk2/pkg-descr
@@ -0,0 +1,4 @@
+Ebview is a gtk based tool to access CD-ROM dictionaries of
+EPWING, EB, EBG,EBXA, EBXA-C formats.
+
+WWW: http://ebview.sourceforge.net/
diff --git a/japanese/ebview-gtk2/pkg-plist b/japanese/ebview-gtk2/pkg-plist
new file mode 100644
index 000000000000..55284a8ff4af
--- /dev/null
+++ b/japanese/ebview-gtk2/pkg-plist
@@ -0,0 +1,5 @@
+bin/ebview
+share/locale/ja/LC_MESSAGES/ebview.mo
+%%PORTDOCS%%share/doc/ebview/ChangeLog
+%%PORTDOCS%%share/doc/ebview/README
+%%PORTDOCS%%@dirrm share/doc/ebview
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
new file mode 100644
index 000000000000..dcdb0423098d
--- /dev/null
+++ b/japanese/ebview/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ebview
+# Date Created: 28 Jan 2002
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ebview
+PORTVERSION= 0.1.4
+CATEGORIES= japanese
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= yoichi@FreeBSD.org
+
+LIB_DEPENDS= eb.6:${PORTSDIR}/japanese/eb
+
+USE_GTK= yes
+USE_IMLIB= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_ARGS= SUBDIRS=src
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/locale/ja/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/po/ja.gmo ${PREFIX}/share/locale/ja/LC_MESSAGES/ebview.mo
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/ebview/distinfo b/japanese/ebview/distinfo
new file mode 100644
index 000000000000..e13c9a70f30d
--- /dev/null
+++ b/japanese/ebview/distinfo
@@ -0,0 +1 @@
+MD5 (ebview-0.1.4.tar.gz) = d95ceca15303c1142c043849eff3efbe
diff --git a/japanese/ebview/pkg-comment b/japanese/ebview/pkg-comment
new file mode 100644
index 000000000000..32cf50dd9312
--- /dev/null
+++ b/japanese/ebview/pkg-comment
@@ -0,0 +1 @@
+Electronic Book Viewer
diff --git a/japanese/ebview/pkg-descr b/japanese/ebview/pkg-descr
new file mode 100644
index 000000000000..2ff8a9ffa8b4
--- /dev/null
+++ b/japanese/ebview/pkg-descr
@@ -0,0 +1,4 @@
+Ebview is a gtk based tool to access CD-ROM dictionaries of
+EPWING, EB, EBG,EBXA, EBXA-C formats.
+
+WWW: http://ebview.sourceforge.net/
diff --git a/japanese/ebview/pkg-plist b/japanese/ebview/pkg-plist
new file mode 100644
index 000000000000..55284a8ff4af
--- /dev/null
+++ b/japanese/ebview/pkg-plist
@@ -0,0 +1,5 @@
+bin/ebview
+share/locale/ja/LC_MESSAGES/ebview.mo
+%%PORTDOCS%%share/doc/ebview/ChangeLog
+%%PORTDOCS%%share/doc/ebview/README
+%%PORTDOCS%%@dirrm share/doc/ebview