aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-10 00:01:09 +0800
committertijl <tijl@FreeBSD.org>2014-08-10 00:01:09 +0800
commit5f2ad416d9f93ef681da03adadcea227372d27d4 (patch)
treef25fd00cf95d1f60fd9e82cb97b96ce75e209ff2 /japanese
parent79732e1ef5ff7bfcf52f8ddcc6fa4af33d3e02b3 (diff)
downloadfreebsd-ports-gnome-5f2ad416d9f93ef681da03adadcea227372d27d4.tar.gz
freebsd-ports-gnome-5f2ad416d9f93ef681da03adadcea227372d27d4.tar.zst
freebsd-ports-gnome-5f2ad416d9f93ef681da03adadcea227372d27d4.zip
- Replace libtool BUILD_DEPENDS with USE_AUTOTOOLS=libtoolize
- Replace STRIP_CMD with INSTALL_TARGET=install-strip - Remove PTHREAD_CFLAGS and PTHREAD_LIBS - Add --copy --force to AUTOMAKE_ARGS so all existing scripts are updated
Diffstat (limited to 'japanese')
-rw-r--r--japanese/mecab/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/japanese/mecab/Makefile b/japanese/mecab/Makefile
index 555a20fc9c43..a89920ae3059 100644
--- a/japanese/mecab/Makefile
+++ b/japanese/mecab/Makefile
@@ -13,26 +13,24 @@ COMMENT= Yet Another Part-of-Speech and Morphological Analyzer
LICENSE= BSD3CLAUSE GPLv2 LGPL21
LICENSE_COMB= multi
-BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/libtool.m4:${PORTSDIR}/devel/libtool
-USE_AUTOTOOLS= autoconf autoheader automake aclocal
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_lib_stdcpp_main=no
+INSTALL_TARGET= install-strip
USES= iconv gettext:build libtool perl5
+USE_AUTOTOOLS= autoconf autoheader automake aclocal libtoolize
+AUTOMAKE_ARGS= --add-missing --copy --force
USE_PERL5= build
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ENV+= ac_cv_lib_stdcpp_main=no
-
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I ${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-AUTOMAKE_ARGS= --add-missing
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS README *.html
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' \
- -e 's/-O3/${CFLAGS}/' ${WRKSRC}/${CONFIGURE_SCRIPT}.in
+ ${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/${CONFIGURE_SCRIPT}.in
${REINPLACE_CMD} -e 's/conf_DATA = mecabrc/conf_DATA = mecabrc.dist/' ${WRKSRC}/Makefile.am
post-configure:
@@ -45,6 +43,5 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:N*.html:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmecab.so
.include <bsd.port.mk>