aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-04-23 16:27:36 +0800
committerknu <knu@FreeBSD.org>2003-04-23 16:27:36 +0800
commitc10f584ad9f74a149d793c517093eef3e1cbcc2a (patch)
treeb1abc081985e5ea6114178d7fad7f8080e017a57 /japanese
parent8adfca5c996228dc6c25afd018d30341d5a94028 (diff)
downloadfreebsd-ports-gnome-c10f584ad9f74a149d793c517093eef3e1cbcc2a.tar.gz
freebsd-ports-gnome-c10f584ad9f74a149d793c517093eef3e1cbcc2a.tar.zst
freebsd-ports-gnome-c10f584ad9f74a149d793c517093eef3e1cbcc2a.zip
Add ruby-mecab, the MeCab library module for Ruby.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/ruby-mecab/Makefile40
-rw-r--r--japanese/ruby-mecab/pkg-descr4
-rw-r--r--japanese/ruby-mecab/pkg-plist2
4 files changed, 47 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index a8e556b9f979..f95695433a64 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -315,6 +315,7 @@
SUBDIR += ruby-gyokuro
SUBDIR += ruby-kakasi
SUBDIR += ruby-man
+ SUBDIR += ruby-mecab
SUBDIR += ruby-refe
SUBDIR += ruby-romkan
SUBDIR += ruby-slang
diff --git a/japanese/ruby-mecab/Makefile b/japanese/ruby-mecab/Makefile
new file mode 100644
index 000000000000..d1c8f41d8178
--- /dev/null
+++ b/japanese/ruby-mecab/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ruby-mecab
+# Date created: 23 April 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${MECAB_PORTNAME}
+PORTVERSION= ${MECAB_PORTVERSION}
+CATEGORIES= japanese textproc ruby
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= MeCab library module for Ruby
+
+EXTRACT_DEPENDS= ${NONEXISTENT}:${MECAB_PORTDIR}:patch
+LIB_DEPENDS= mecab.0:${MECAB_PORTDIR}
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
+
+.include "${.CURDIR}/../mecab/Makefile.common"
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${LN} -fs `${MECAB_WRKSRC_CMD}`/ruby ${WRKSRC}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/mecab
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${PREFIX}/share/examples/mecab/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/ruby-mecab/pkg-descr b/japanese/ruby-mecab/pkg-descr
new file mode 100644
index 000000000000..fd7f9c91d361
--- /dev/null
+++ b/japanese/ruby-mecab/pkg-descr
@@ -0,0 +1,4 @@
+This is the MeCab library module for Ruby.
+
+Author: Taku Kudoh <taku-ku@is.aist-nara.ac.jp>
+WWW: http://cl.aist-nara.ac.jp/~taku-ku/software/mecab/
diff --git a/japanese/ruby-mecab/pkg-plist b/japanese/ruby-mecab/pkg-plist
new file mode 100644
index 000000000000..67daf7399869
--- /dev/null
+++ b/japanese/ruby-mecab/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITEARCHLIBDIR%%/MeCab.so
+%%PORTDOCS%%share/examples/mecab/test.rb