aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commitbcc2006e5a05ff46461202f4b3c0a4ac8d86476e (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /japanese
parent27befbedb683f9336783ae19591c9b2f5037500d (diff)
downloadfreebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.gz
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.zst
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Wnn7-lib/Makefile1
-rw-r--r--japanese/canna-lib/Makefile1
-rw-r--r--japanese/groff/Makefile1
-rw-r--r--japanese/sj3-lib/Makefile1
-rw-r--r--japanese/skk-tools/Makefile1
-rw-r--r--japanese/texfamily/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/japanese/Wnn7-lib/Makefile b/japanese/Wnn7-lib/Makefile
index 78daeef1d0cc..a7a2e3b2dd98 100644
--- a/japanese/Wnn7-lib/Makefile
+++ b/japanese/Wnn7-lib/Makefile
@@ -16,6 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= hrs@FreeBSD.org
COMMENT= Wnn7 client library
+USE_GCC= any
USE_IMAKE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/src
diff --git a/japanese/canna-lib/Makefile b/japanese/canna-lib/Makefile
index e9c426b54dc7..c352ed792fae 100644
--- a/japanese/canna-lib/Makefile
+++ b/japanese/canna-lib/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= A Kana-to-Kanji conversion system, library part
USE_BZIP2= yes
+USE_GCC= any
USE_IMAKE= yes
USE_LDCONFIG= yes
NO_INSTALL_MANPAGES=yes
diff --git a/japanese/groff/Makefile b/japanese/groff/Makefile
index 8d1e9946fa10..e8ff345158b3 100644
--- a/japanese/groff/Makefile
+++ b/japanese/groff/Makefile
@@ -30,6 +30,7 @@ RUN_DEPENDS= pnmcut:${PORTSDIR}/graphics/netpbm
TMAC_DATE= 20030521
TMAC_DISTNAME= tmac-${TMAC_DATE}_2
+USE_GCC= any
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/japanese/sj3-lib/Makefile b/japanese/sj3-lib/Makefile
index 8faf2c639139..1c00bdca0eb7 100644
--- a/japanese/sj3-lib/Makefile
+++ b/japanese/sj3-lib/Makefile
@@ -19,6 +19,7 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= hrs@FreeBSD.org
COMMENT= A Japanese input method, library part
+USE_GCC= any
USE_IMAKE= yes
USE_LDCONFIG= yes
NO_INSTALL_MANPAGES= yes
diff --git a/japanese/skk-tools/Makefile b/japanese/skk-tools/Makefile
index 904c414cd9f0..b6e681b90acf 100644
--- a/japanese/skk-tools/Makefile
+++ b/japanese/skk-tools/Makefile
@@ -22,6 +22,7 @@ OPTIONS_DEFINE= EXPR2
OPTIONS_DEFAULT= EXPR2
EXPR2_DESC= Build skkdic-expr2 (needs glib-2.x)
+USE_GCC= any
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
diff --git a/japanese/texfamily/Makefile b/japanese/texfamily/Makefile
index 2884368abe5b..5d44b3f9ebf8 100644
--- a/japanese/texfamily/Makefile
+++ b/japanese/texfamily/Makefile
@@ -36,6 +36,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
wwwcore.1:${PORTSDIR}/www/libwww \
t1.5:${PORTSDIR}/devel/t1lib
+USE_GCC= any
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${KANJICODE}
CONFIGURE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}" \