aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-07-12 12:22:39 +0800
committernivit <nivit@FreeBSD.org>2014-07-12 12:22:39 +0800
commitf3345d22d845782db86ef5fe385cc84730aebe7f (patch)
treeb8c8e69057092ed717a2fbc87aff410ad503a6f0 /japanese
parent9cdae7844c0ebd40d857f589561bd12b8ca2bb44 (diff)
downloadfreebsd-ports-gnome-f3345d22d845782db86ef5fe385cc84730aebe7f.tar.gz
freebsd-ports-gnome-f3345d22d845782db86ef5fe385cc84730aebe7f.tar.zst
freebsd-ports-gnome-f3345d22d845782db86ef5fe385cc84730aebe7f.zip
- Update to 158
- Update MASTER_SITES - Add LICENSE (GPLv2) - Add support for stage-dir (with a different approach from the related PR [1]) - Add files/slimeforest.sh.in PR: 187879 [1] Submitted by: <xmj@chaot.net>
Diffstat (limited to 'japanese')
-rw-r--r--japanese/slimeforest/Makefile52
-rw-r--r--japanese/slimeforest/distinfo4
-rw-r--r--japanese/slimeforest/files/slimeforest.sh.in13
-rw-r--r--japanese/slimeforest/pkg-plist154
4 files changed, 48 insertions, 175 deletions
diff --git a/japanese/slimeforest/Makefile b/japanese/slimeforest/Makefile
index 4428d3155448..78b82bfdabf7 100644
--- a/japanese/slimeforest/Makefile
+++ b/japanese/slimeforest/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= slimeforest
-PORTVERSION= 0.60
-PORTREVISION= 1
+PORTVERSION= 158
+PORTREVISION= 0
CATEGORIES= japanese games linux
-MASTER_SITES= http://nivi.interfree.it/distfiles/${DIST_SUBDIR}/ \
+MASTER_SITES= http://nivit.altervista.org/FreeBSD/ports/distfiles/${DIST_SUBDIR}/ \
http://lrnj.com/
DISTNAME= sfa
EXTRACT_SUFX= .tgz
@@ -14,43 +14,27 @@ DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
MAINTAINER= nivit@FreeBSD.org
COMMENT= NES RPG game for learning KANA and KANJI (Linux version)
+LICENSE= GPLv2
+
NO_BUILD= yes
+
+PLIST_SUB= BINMODE=${BINMODE}
+
+SUB_FILES= ${PORTNAME}.sh
+
USE_LINUX= yes
USE_LINUX_APPS= sdlimage
WRKSRC= ${WRKDIR}/slimeforest
-FIND_DIRS= -type d \! -empty
-FIND_EXEC= \! -type d -and -perm -a+x \! -name "*.bak" \! -name "*.orig"
-FIND_DATA= \! -type d -and \! -perm -a+x -and \! -name "*.txt"
-LINK_OPTS= -s
-
-REPLACE_FILES= runfs runwin
-
-NO_STAGE= yes
-post-patch:
- @for FILE in ${REPLACE_FILES}; do \
- ${SED} -i .bak\
- -e "/\`dirname.*\`/s//${DATADIR:S/\//\\\//g}/g" \
- ${WRKSRC}/$${FILE}; \
- done;
do-install:
-# programs and data
- @cd ${WRKSRC}; \
- DIRS=$$(${FIND} . ${FIND_DIRS}); \
- for DIR in $${DIRS}; do \
- ${MKDIR} ${DATADIR}/$${DIR}; \
- done; \
- FILES=$$(${FIND} . ${FIND_EXEC} ); \
- for FILE in $${FILES}; do \
- ${INSTALL_SCRIPT} $${FILE} ${DATADIR}/$${FILE}; \
- done; \
- FILES=$$(${FIND} . ${FIND_DATA}); \
- for FILE in $${FILES}; do \
- ${INSTALL_DATA} $${FILE} ${DATADIR}/$${FILE}; \
- done;
-# links to executables
- ${LN} ${LINK_OPTS} ${DATADIR}/runfs ${PREFIX}/bin/slimeforest-fs
- ${LN} ${LINK_OPTS} ${DATADIR}/runwin ${PREFIX}/bin/slimeforest-win
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/jquest && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} \
+ '! -name *\.bak -and ! -name *\.txt -and ! -name jquest64')
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}.sh
+ @${LN} -sf slimeforest.sh ${STAGEDIR}${PREFIX}/bin/slimeforest-fs
+ @${LN} -sf slimeforest.sh ${STAGEDIR}${PREFIX}/bin/slimeforest-win
.include <bsd.port.mk>
diff --git a/japanese/slimeforest/distinfo b/japanese/slimeforest/distinfo
index b3005066d284..9c3dd3f25963 100644
--- a/japanese/slimeforest/distinfo
+++ b/japanese/slimeforest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (slimeforest/0.60/sfa.tgz) = 7bf2fbb90853efc28d5cd8c0f855024aca54f42b9fe69674a83e929966155e6a
-SIZE (slimeforest/0.60/sfa.tgz) = 1285915
+SHA256 (slimeforest/158/sfa.tgz) = df55ee401a1cb82842dc6630186a94ba3ef98f3c433aee20232061b70350180b
+SIZE (slimeforest/158/sfa.tgz) = 4231000
diff --git a/japanese/slimeforest/files/slimeforest.sh.in b/japanese/slimeforest/files/slimeforest.sh.in
new file mode 100644
index 000000000000..ce8b17407733
--- /dev/null
+++ b/japanese/slimeforest/files/slimeforest.sh.in
@@ -0,0 +1,13 @@
+#!/bin/sh
+cd ${HOME}
+if [ ! -d .slimeforest ]; then
+ mkdir .slimeforest
+ cd .slimeforest
+ mkdir playerdata
+ for f in images jad.wad maps exec.ver playerdata/data.ver sfd.wad
+ do
+ ln -sf %%DATADIR%%/${f} ${f}
+ done
+fi
+cd ${HOME}/.slimeforest
+%%DATADIR%%/jquest
diff --git a/japanese/slimeforest/pkg-plist b/japanese/slimeforest/pkg-plist
index 3c443b009dc6..97504a705ea9 100644
--- a/japanese/slimeforest/pkg-plist
+++ b/japanese/slimeforest/pkg-plist
@@ -1,141 +1,17 @@
bin/slimeforest-fs
bin/slimeforest-win
-%%DATADIR%%/jquest/exec.ver
-%%DATADIR%%/jquest/images/axehero.png
-%%DATADIR%%/jquest/images/axeknight.png
-%%DATADIR%%/jquest/images/basic.font
-%%DATADIR%%/jquest/images/bedtile.png
-%%DATADIR%%/jquest/images/bkframe.png
-%%DATADIR%%/jquest/images/blacktile.png
-%%DATADIR%%/jquest/images/blocktile.png
-%%DATADIR%%/jquest/images/blueblop.png
-%%DATADIR%%/jquest/images/blueslime.png
-%%DATADIR%%/jquest/images/brother.png
-%%DATADIR%%/jquest/images/castletile.png
-%%DATADIR%%/jquest/images/cavebg.jpg
-%%DATADIR%%/jquest/images/cavetile.png
-%%DATADIR%%/jquest/images/chest.png
-%%DATADIR%%/jquest/images/chunkyman.png
-%%DATADIR%%/jquest/images/closeddoortile.png
-%%DATADIR%%/jquest/images/countertile.png
-%%DATADIR%%/jquest/images/dasilva.png
-%%DATADIR%%/jquest/images/dirttile.png
-%%DATADIR%%/jquest/images/doortile.png
-%%DATADIR%%/jquest/images/downtile.png
-%%DATADIR%%/jquest/images/drawbackaxe.png
-%%DATADIR%%/jquest/images/drawbackhoe.png
-%%DATADIR%%/jquest/images/elder.png
-%%DATADIR%%/jquest/images/explainbug.png
-%%DATADIR%%/jquest/images/farmhero.png
-%%DATADIR%%/jquest/images/farmknight.png
-%%DATADIR%%/jquest/images/field0tile.png
-%%DATADIR%%/jquest/images/field1tile.png
-%%DATADIR%%/jquest/images/field2tile.png
-%%DATADIR%%/jquest/images/field3tile.png
-%%DATADIR%%/jquest/images/fire.png
-%%DATADIR%%/jquest/images/fireball.png
-%%DATADIR%%/jquest/images/flarepotato.png
-%%DATADIR%%/jquest/images/floortile.png
-%%DATADIR%%/jquest/images/forestbg.jpg
-%%DATADIR%%/jquest/images/ghostking.png
-%%DATADIR%%/jquest/images/giantslime.png
-%%DATADIR%%/jquest/images/grassbg.jpg
-%%DATADIR%%/jquest/images/grasstile.png
-%%DATADIR%%/jquest/images/greenblop.png
-%%DATADIR%%/jquest/images/greenpipe.png
-%%DATADIR%%/jquest/images/greenslime.png
-%%DATADIR%%/jquest/images/hilltile.png
-%%DATADIR%%/jquest/images/hometile.png
-%%DATADIR%%/jquest/images/ironrock.png
-%%DATADIR%%/jquest/images/kanji16.font
-%%DATADIR%%/jquest/images/kanji48.font
-%%DATADIR%%/jquest/images/kdrawbackaxe.png
-%%DATADIR%%/jquest/images/kdrawbackhoe.png
-%%DATADIR%%/jquest/images/king.png
-%%DATADIR%%/jquest/images/kstandingaxe.png
-%%DATADIR%%/jquest/images/kstandinghoe.png
-%%DATADIR%%/jquest/images/kstrikeaxe.png
-%%DATADIR%%/jquest/images/kstrikehoe.png
-%%DATADIR%%/jquest/images/magislime.png
-%%DATADIR%%/jquest/images/magnetslime.png
-%%DATADIR%%/jquest/images/magnetzap.png
-%%DATADIR%%/jquest/images/merchant.png
-%%DATADIR%%/jquest/images/metalslime.png
-%%DATADIR%%/jquest/images/mountaintile.png
-%%DATADIR%%/jquest/images/mudbricktile.png
-%%DATADIR%%/jquest/images/ninjaslime.png
-%%DATADIR%%/jquest/images/pipe.png
-%%DATADIR%%/jquest/images/pirate.png
-%%DATADIR%%/jquest/images/princess.png
-%%DATADIR%%/jquest/images/redblop.png
-%%DATADIR%%/jquest/images/redpipe.png
-%%DATADIR%%/jquest/images/redslime.png
-%%DATADIR%%/jquest/images/rkframe.png
-%%DATADIR%%/jquest/images/roadtile.png
-%%DATADIR%%/jquest/images/rooftile.png
-%%DATADIR%%/jquest/images/sfatitle.png
-%%DATADIR%%/jquest/images/ship.png
-%%DATADIR%%/jquest/images/shiphero.png
-%%DATADIR%%/jquest/images/shipknight.png
-%%DATADIR%%/jquest/images/shuriken1.png
-%%DATADIR%%/jquest/images/shuriken2.png
-%%DATADIR%%/jquest/images/soldier.png
-%%DATADIR%%/jquest/images/standingaxe.png
-%%DATADIR%%/jquest/images/standinghoe.png
-%%DATADIR%%/jquest/images/strawtile.png
-%%DATADIR%%/jquest/images/strikeaxe.png
-%%DATADIR%%/jquest/images/strikehoe.png
-%%DATADIR%%/jquest/images/treetile.png
-%%DATADIR%%/jquest/images/uptile.png
-%%DATADIR%%/jquest/images/villageman.png
-%%DATADIR%%/jquest/images/villagetile.png
-%%DATADIR%%/jquest/images/villagewoman.png
-%%DATADIR%%/jquest/images/walltile.png
-%%DATADIR%%/jquest/images/warslime.png
-%%DATADIR%%/jquest/images/watertile.png
-%%DATADIR%%/jquest/images/wbkframe.png
-%%DATADIR%%/jquest/images/wetile.png
-%%DATADIR%%/jquest/images/wnetile.png
-%%DATADIR%%/jquest/images/wntile.png
-%%DATADIR%%/jquest/images/wnwtile.png
-%%DATADIR%%/jquest/images/wrkframe.png
-%%DATADIR%%/jquest/images/wsetile.png
-%%DATADIR%%/jquest/images/wstile.png
-%%DATADIR%%/jquest/images/wswtile.png
-%%DATADIR%%/jquest/images/wwtile.png
-%%DATADIR%%/jquest/jquest
-%%DATADIR%%/jquest/languagedata/hints.data
-%%DATADIR%%/jquest/languagedata/hiragana.data
-%%DATADIR%%/jquest/languagedata/kanji.data
-%%DATADIR%%/jquest/languagedata/katakana.data
-%%DATADIR%%/jquest/maps/amulethome.map
-%%DATADIR%%/jquest/maps/barracks.map
-%%DATADIR%%/jquest/maps/castle.map
-%%DATADIR%%/jquest/maps/cave.map
-%%DATADIR%%/jquest/maps/cave2.map
-%%DATADIR%%/jquest/maps/cave3.map
-%%DATADIR%%/jquest/maps/cave4.map
-%%DATADIR%%/jquest/maps/elderhome.map
-%%DATADIR%%/jquest/maps/getout.map
-%%DATADIR%%/jquest/maps/home.map
-%%DATADIR%%/jquest/maps/inn.map
-%%DATADIR%%/jquest/maps/poorlady.map
-%%DATADIR%%/jquest/maps/sfoverworld.map
-%%DATADIR%%/jquest/maps/shop.map
-%%DATADIR%%/jquest/maps/slimecastle.map
-%%DATADIR%%/jquest/maps/slimecave.map
-%%DATADIR%%/jquest/maps/slimecave2.map
-%%DATADIR%%/jquest/maps/slimecave3.map
-%%DATADIR%%/jquest/maps/slimecave4.map
-%%DATADIR%%/jquest/maps/slimeisland.map
-%%DATADIR%%/jquest/maps/throneroom.map
-%%DATADIR%%/jquest/maps/village.map
-%%DATADIR%%/jquest/playerdata/data.ver
-%%DATADIR%%/runfs
-%%DATADIR%%/runwin
-@dirrm %%DATADIR%%/jquest/images
-@dirrm %%DATADIR%%/jquest/languagedata
-@dirrm %%DATADIR%%/jquest/maps
-@dirrm %%DATADIR%%/jquest/playerdata
-@dirrm %%DATADIR%%/jquest
-@dirrm %%DATADIR%%
+bin/slimeforest.sh
+%%DATADIR%%/exec.ver
+%%DATADIR%%/images/greenslime.png
+%%DATADIR%%/jad.wad
+%%DATADIR%%/jquest
+@mode %%BINMODE%%
+%%DATADIR%%/jquest32
+@mode
+%%DATADIR%%/maps/forest.map
+%%DATADIR%%/playerdata/data.ver
+%%DATADIR%%/sfd.wad
+@dirrmtry %%DATADIR%%/images
+@dirrmtry %%DATADIR%%/maps
+@dirrmtry %%DATADIR%%/playerdata
+@dirrmtry %%DATADIR%%