aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-01 04:58:12 +0800
committerbapt <bapt@FreeBSD.org>2014-07-01 04:58:12 +0800
commit0315e2a0fbf139229f08e70411dbb4c41e990e37 (patch)
tree83cc0edbbcbe31b97dba1fcf11cc85f2f204a398 /japanese
parentf4c9869290d4fc100adcc6cc79a1e386f3eacb32 (diff)
downloadfreebsd-ports-gnome-0315e2a0fbf139229f08e70411dbb4c41e990e37.tar.gz
freebsd-ports-gnome-0315e2a0fbf139229f08e70411dbb4c41e990e37.tar.zst
freebsd-ports-gnome-0315e2a0fbf139229f08e70411dbb4c41e990e37.zip
Support stage [1]
While here: - Use options helpers when possible - Remove update-desktop-database (it is useless for this port) PR: 190661 Submitted by: darksoul@darkbsd.org
Diffstat (limited to 'japanese')
-rw-r--r--japanese/gjiten/Makefile46
-rw-r--r--japanese/gjiten/pkg-plist5
2 files changed, 19 insertions, 32 deletions
diff --git a/japanese/gjiten/Makefile b/japanese/gjiten/Makefile
index a90dbf8acf68..73352f40c6cc 100644
--- a/japanese/gjiten/Makefile
+++ b/japanese/gjiten/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gjiten
PORTVERSION= 2.6
+PORTREVISION= 1
CATEGORIES= japanese gnome
MASTER_SITES= http://gjiten.sourceforge.net/
@@ -14,26 +15,27 @@ UTF8_DESC= Use UTF-8 edict dictionaries
KANJIPAD_DESC= Use Kanjipad
USE_GNOME= gtk20 gconf2 libglade2 libgnomeui
-USES= gmake pkgconfig
+USES= gmake libtool pkgconfig
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= gjiten-doc.ja.html
-MAN1= gjiten.1
GCONF_SCHEMAS= gjiten-dicfiles.schemas gjiten.schemas
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-MAKE_ENV+= USE_NLS=no
-.endif
+NLS_USES= gettext
+NLS_MAKE_ENV_OFF= USE_NLS=no
+
+KANJIPAD_RUN_DEPENDS= ${LOCALBASE}/bin/kanjipad:${PORTSDIR}/japanese/kanjipad
+BUILD_DEPENDS= ${LOCALBASE}/bin/xmlto:${PORTSDIR}/textproc/xmlto
+
+DICTIONARIES= kanjidic edict compdic
+GJITEN_DICS= ${DATADIR}/dics/
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUTF8}
EDICT_DIR= ${LOCALBASE}/share/dict/edict-utf-8
@@ -46,32 +48,20 @@ RUN_DEPENDS+= ${EDICT_FILE}:${PORTSDIR}/japanese/edict
USES+= iconv:build
.endif
-DICTIONARIES= kanjidic edict compdic
-GJITEN_DICS= ${DATADIR}/dics/
-
-.if ${PORT_OPTIONS:MKANJIPAD}
-RUN_DEPENDS+= ${LOCALBASE}/bin/kanjipad:${PORTSDIR}/japanese/kanjipad
-.endif
-
-BUILD_DEPENDS+= ${LOCALBASE}/bin/xmlto:${PORTSDIR}/textproc/xmlto
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL} -d ${DOCSDIR}
+ ${INSTALL} -d ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/help/ja/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/help/ja/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${INSTALL} -d ${GJITEN_DICS}
+ ${INSTALL} -d ${STAGEDIR}${GJITEN_DICS}
.if ${PORT_OPTIONS:MUTF8}
.for f in ${DICTIONARIES}
- ${INSTALL_DATA} ${EDICT_DIR}/${f} ${GJITEN_DICS}
+ ${INSTALL_DATA} ${EDICT_DIR}/${f} ${STAGEDIR}${GJITEN_DICS}
.endfor
.else
.for f in ${DICTIONARIES}
- ${ICONV_CMD} -c -f EUC-JP -t UTF-8 ${EDICT_DIR}/${f} > ${GJITEN_DICS}/${f}
+ ${ICONV_CMD} -c -f EUC-JP -t UTF-8 ${EDICT_DIR}/${f} > ${STAGEDIR}${GJITEN_DICS}/${f}
.endfor
.endif
- -@update-desktop-database
.include <bsd.port.mk>
diff --git a/japanese/gjiten/pkg-plist b/japanese/gjiten/pkg-plist
index 3f7c77376842..0f79c4422a4b 100644
--- a/japanese/gjiten/pkg-plist
+++ b/japanese/gjiten/pkg-plist
@@ -1,4 +1,5 @@
bin/gjiten
+man/man1/gjiten.1.gz
share/application-registry/gjiten.desktop
share/applications/gjiten.desktop
%%DATADIR%%/dics/compdic
@@ -26,7 +27,3 @@ share/pixmaps/left_ptr_question.png
@dirrmtry share/locale/de_CH
@dirrmtry share/gnome/help/gjiten/C
@dirrmtry share/gnome/help/gjiten
-@dirrmtry share/gnome/help
-@dirrmtry share/gnome
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true