aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2014-11-11 21:41:37 +0800
committerrobak <robak@FreeBSD.org>2014-11-11 21:41:37 +0800
commitef39b1426a712146e348383a9f4d27a5f70c7894 (patch)
treebf11bc6b43cc0936f7e9af943553897b2405fc58 /japanese
parent80c8895e9d4a9b95bb6e0367dade60e3cc2ecd52 (diff)
downloadfreebsd-ports-gnome-ef39b1426a712146e348383a9f4d27a5f70c7894.tar.gz
freebsd-ports-gnome-ef39b1426a712146e348383a9f4d27a5f70c7894.tar.zst
freebsd-ports-gnome-ef39b1426a712146e348383a9f4d27a5f70c7894.zip
japanese/mh: fixes
- Strip binaries and libs - Add missing patch PR: 194880 Submitted by: Watanabe Kazuhiro <CQG00620@nifty.ne.jp> Approved by: mentors (implicit)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/mh/Makefile7
-rw-r--r--japanese/mh/files/patch-conf__makefiles__uip13
2 files changed, 19 insertions, 1 deletions
diff --git a/japanese/mh/Makefile b/japanese/mh/Makefile
index 788495029678..9372e2c1745b 100644
--- a/japanese/mh/Makefile
+++ b/japanese/mh/Makefile
@@ -41,10 +41,15 @@ OPTIONS_DEFINE= DOCS
post-patch:
${REINPLACE_CMD} -e "s/-O /${CFLAGS} /g" ${WRKSRC}/configure
-.if ${PORT_OPTIONS:MDOCS}
post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc-JP && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.endif
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmh.so.3
+.for i in ap conflict dp fmtdump install-mh mhl post rcvdist rcvpack rcvstore rcvtty slocal spost
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mh/${i}
+.endfor
.include <bsd.port.mk>
diff --git a/japanese/mh/files/patch-conf__makefiles__uip b/japanese/mh/files/patch-conf__makefiles__uip
new file mode 100644
index 000000000000..578964fdd28f
--- /dev/null
+++ b/japanese/mh/files/patch-conf__makefiles__uip
@@ -0,0 +1,13 @@
+--- conf/makefiles/uip.orig 2001-05-30 23:57:47.000000000 +0900
++++ conf/makefiles/uip 2014-10-13 17:55:46.000000000 +0900
+@@ -995,10 +995,6 @@
+ -chmod g-s zrcvtty
+ $(CP) xrcvtty $@
+ -@chmod $(PGMPROT) $@
+-@BEGIN: BSD43
+- -@chgrp tty $@
+- -@chmod g+s $@
+-@END: BSD43
+ -@ls -l $@
+ -@echo ""
+