aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /japanese
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'japanese')
-rw-r--r--japanese/anthy/Makefile2
-rw-r--r--japanese/eb/Makefile2
-rw-r--r--japanese/eb3/Makefile2
-rw-r--r--japanese/im-ja/Makefile2
-rw-r--r--japanese/libicq/Makefile2
-rw-r--r--japanese/uim/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/japanese/anthy/Makefile b/japanese/anthy/Makefile
index 6dc4a338a657..af04f2a72b15 100644
--- a/japanese/anthy/Makefile
+++ b/japanese/anthy/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Another kana-kanji conversion system
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_GNOME= lthack
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 97f97357fddf..e9d7f416680f 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -60,7 +60,7 @@ DIST_SUBDIR= eb
USE_GETTEXT= yes
USE_PERL5= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-nls \
diff --git a/japanese/eb3/Makefile b/japanese/eb3/Makefile
index 97f97357fddf..e9d7f416680f 100644
--- a/japanese/eb3/Makefile
+++ b/japanese/eb3/Makefile
@@ -60,7 +60,7 @@ DIST_SUBDIR= eb
USE_GETTEXT= yes
USE_PERL5= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-nls \
diff --git a/japanese/im-ja/Makefile b/japanese/im-ja/Makefile
index 0ec91229ce5b..4ab2eba51356 100644
--- a/japanese/im-ja/Makefile
+++ b/japanese/im-ja/Makefile
@@ -19,7 +19,7 @@ OPTIONS+= WNN "Use FreeWnn" on
USE_PERL5_BUILD= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomeprefix gnomehack gnomepanel
GNU_CONFIGURE= yes
diff --git a/japanese/libicq/Makefile b/japanese/libicq/Makefile
index 67b45276e97c..ff4f23b4a463 100644
--- a/japanese/libicq/Makefile
+++ b/japanese/libicq/Makefile
@@ -22,7 +22,7 @@ MAINTAINER= flathill@FreeBSD.org
COMMENT= Library to add ICQ communication support to your software
USE_GNOME= glib12
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/japanese/uim/Makefile b/japanese/uim/Makefile
index dccc5375c264..b863d76e96b7 100644
--- a/japanese/uim/Makefile
+++ b/japanese/uim/Makefile
@@ -25,7 +25,7 @@ WANT_GNOME= yes
USE_GNOME= lthack gnometarget glib20
USE_GMAKE= yes
USE_ICONV= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"