aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-02-23 01:04:33 +0800
committerknu <knu@FreeBSD.org>2003-02-23 01:04:33 +0800
commit8c62d98c7854cd5c4ab49faebb1829bb632264f0 (patch)
treec102063d8865a3e94475bc83e5e402a4f7d49058 /japanese
parent92374231b365b9b586d54b85efcc53ec1aa1e1e0 (diff)
downloadfreebsd-ports-gnome-8c62d98c7854cd5c4ab49faebb1829bb632264f0.tar.gz
freebsd-ports-gnome-8c62d98c7854cd5c4ab49faebb1829bb632264f0.tar.zst
freebsd-ports-gnome-8c62d98c7854cd5c4ab49faebb1829bb632264f0.zip
Avoid the use of tar(1)'s --no-same-owner flag, which is not supported
by version 1.11.2 or earlier. This fixes installation on older systems prior to 4.7-RELEASE. PR: ports/42143 (no patch) Submitted by: Kimura Fuyuki <fuyuki@hadaly.org>
Diffstat (limited to 'japanese')
-rw-r--r--japanese/eb/Makefile10
-rw-r--r--japanese/eb2/Makefile10
-rw-r--r--japanese/eb3/Makefile10
3 files changed, 18 insertions, 12 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 581f0de8f58f..e53abf697d25 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -70,14 +70,16 @@ APPENDIXDIR= ${PREFIX}/share/eb/appendix
pre-configure:
cd ${WRKSRC}; autoconf
+ ${MKDIR} ${WRKDIR}/appendix
+.for file in ${APPENDIXFILES}
+ ${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
+ ${DISTDIR}/${DIST_SUBDIR}/${file}
+.endfor
post-install:
.for file in ${LISTFILES}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${file} ${APPENDIXDIR}
.endfor
-.for file in ${APPENDIXFILES}
- ${TAR} --no-same-owner --exclude CVS -C ${APPENDIXDIR} -zxmf\
- ${DISTDIR}/${DIST_SUBDIR}/${file}
-.endfor
+ ${CP} -R ${WRKDIR}/appendix/ ${APPENDIXDIR}
.include <bsd.port.mk>
diff --git a/japanese/eb2/Makefile b/japanese/eb2/Makefile
index 226366e854fe..a5cccfa90d19 100644
--- a/japanese/eb2/Makefile
+++ b/japanese/eb2/Makefile
@@ -62,14 +62,16 @@ APPENDIXDIR= ${PREFIX}/share/eb/appendix
post-extract:
cd ${WRKSRC} && ${RM} -rf zlib
+ ${MKDIR} ${WRKDIR}/appendix
+.for file in ${APPENDIXFILES}
+ ${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
+ ${DISTDIR}/${DIST_SUBDIR}/${file}
+.endfor
post-install:
.for file in ${LISTFILES}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${file} ${APPENDIXDIR}
.endfor
-.for file in ${APPENDIXFILES}
- ${TAR} --no-same-owner --exclude CVS -C ${APPENDIXDIR} -zxmf\
- ${DISTDIR}/${DIST_SUBDIR}/${file}
-.endfor
+ ${CP} -R ${WRKDIR}/appendix/ ${APPENDIXDIR}
.include <bsd.port.mk>
diff --git a/japanese/eb3/Makefile b/japanese/eb3/Makefile
index 581f0de8f58f..e53abf697d25 100644
--- a/japanese/eb3/Makefile
+++ b/japanese/eb3/Makefile
@@ -70,14 +70,16 @@ APPENDIXDIR= ${PREFIX}/share/eb/appendix
pre-configure:
cd ${WRKSRC}; autoconf
+ ${MKDIR} ${WRKDIR}/appendix
+.for file in ${APPENDIXFILES}
+ ${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
+ ${DISTDIR}/${DIST_SUBDIR}/${file}
+.endfor
post-install:
.for file in ${LISTFILES}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${file} ${APPENDIXDIR}
.endfor
-.for file in ${APPENDIXFILES}
- ${TAR} --no-same-owner --exclude CVS -C ${APPENDIXDIR} -zxmf\
- ${DISTDIR}/${DIST_SUBDIR}/${file}
-.endfor
+ ${CP} -R ${WRKDIR}/appendix/ ${APPENDIXDIR}
.include <bsd.port.mk>