aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-09-06 02:26:28 +0800
committerknu <knu@FreeBSD.org>2000-09-06 02:26:28 +0800
commita0c49a8e0f96b81ba94ccefae9d9bb3fe61fe768 (patch)
tree4fd23d3532191fb590c7f01e483ecced0138fea6 /japanese
parent6cc3c8d4a22b45c7508a4d8b77eda61ea73c5fe8 (diff)
downloadfreebsd-ports-gnome-a0c49a8e0f96b81ba94ccefae9d9bb3fe61fe768.tar.gz
freebsd-ports-gnome-a0c49a8e0f96b81ba94ccefae9d9bb3fe61fe768.tar.zst
freebsd-ports-gnome-a0c49a8e0f96b81ba94ccefae9d9bb3fe61fe768.zip
Add ruby-eb, Ruby bind of EB library.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/ruby-eb/Makefile46
-rw-r--r--japanese/ruby-eb/distinfo1
-rw-r--r--japanese/ruby-eb/pkg-comment1
-rw-r--r--japanese/ruby-eb/pkg-descr5
-rw-r--r--japanese/ruby-eb/pkg-plist7
6 files changed, 61 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index 2d08e5647b32..3721d4f62769 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -233,6 +233,7 @@
SUBDIR += recjis
SUBDIR += rogue_s
SUBDIR += rskkserv
+ SUBDIR += ruby-eb
SUBDIR += ruby-kakasi
SUBDIR += ruby-man
SUBDIR += ruby-slang
diff --git a/japanese/ruby-eb/Makefile b/japanese/ruby-eb/Makefile
new file mode 100644
index 000000000000..193c2a3b4391
--- /dev/null
+++ b/japanese/ruby-eb/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: Ruby EB
+# Date created: 6 Sep 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eb
+PORTVERSION= 1.4
+CATEGORIES= japanese ruby
+MASTER_SITES= http://www.osk.3web.ne.jp/~nyasu/software/
+DISTNAME= ruby-${PORTNAME}${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= eb.3:${PORTSDIR}/japanese/eb
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_WRKSUBDIR= yes
+CONFIGURE_ARGS= --with-opt-dir="${LOCALBASE}"
+INSTALL_TARGET= site-install
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}ruby-
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/ruby/eb/ja/
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${PREFIX}/share/examples/ruby/eb/ja/
+ ${MKDIR} ${PREFIX}/share/doc/ruby/eb/ja
+ ${INSTALL_DATA} ${WRKSRC}/eb.html ${PREFIX}/share/doc/ruby/eb/ja/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/ruby-eb/distinfo b/japanese/ruby-eb/distinfo
new file mode 100644
index 000000000000..32cbcd9a8a36
--- /dev/null
+++ b/japanese/ruby-eb/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-eb1.4.tar.gz) = f7645b29da2c77318b2b4e20959cde2c
diff --git a/japanese/ruby-eb/pkg-comment b/japanese/ruby-eb/pkg-comment
new file mode 100644
index 000000000000..23021815984e
--- /dev/null
+++ b/japanese/ruby-eb/pkg-comment
@@ -0,0 +1 @@
+Ruby bind of EB library
diff --git a/japanese/ruby-eb/pkg-descr b/japanese/ruby-eb/pkg-descr
new file mode 100644
index 000000000000..0319eec3bebf
--- /dev/null
+++ b/japanese/ruby-eb/pkg-descr
@@ -0,0 +1,5 @@
+Ruby EB -- Ruby bind of EB library.
+
+
+Author: Nishikawa,Yasuhiro <nyasu@osk.3web.ne.jp>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=RubyEB
diff --git a/japanese/ruby-eb/pkg-plist b/japanese/ruby-eb/pkg-plist
new file mode 100644
index 000000000000..399d77563d1c
--- /dev/null
+++ b/japanese/ruby-eb/pkg-plist
@@ -0,0 +1,7 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/eb.so
+share/examples/ruby/eb/ja/test.rb
+@dirrm share/examples/ruby/eb/ja
+@dirrm share/examples/ruby/eb
+share/doc/ruby/eb/ja/eb.html
+@dirrm share/doc/ruby/eb/ja
+@dirrm share/doc/ruby/eb
0ef1406e2df79219a9f8bd2dca1a34aed136d'>- fix pkglistdinoex2003-06-101-0/+5 * Update to 0.52.adamw2003-06-103-3/+4 * REST IN PEACEwill2003-06-091-1/+1 * - Mark as BROKEN on 4-stable (requires readline 4.2 or newer)ijliao2003-06-074-21/+56 * Update deskutils/logjam2: upgrade and fix configure erroredwin2003-06-054-12/+43 * Move inclusion of bsd.port.pre.mk later in the file for conditional BROKENkris2003-06-051-4/+4 * Assign MAINTAINER to ports@FreeBSD.org.adamw2003-06-051-1/+1 * upgrade to 0.5.5ijliao2003-06-035-33/+57 * - Add WITH_GNUSTEP_DEVELdinoex2003-06-011-16/+226 * - Add WITH_GNUSTEP_DEVELdinoex2003-06-011-3/+3 * * Update to 2.2.3marcus2003-06-016-8/+12 * Fix build on -CURRENTarved2003-05-2311-34/+128 * Upgrade to 011.obraun2003-05-222-13/+7 * Update to 0.51.adamw2003-05-213-6/+10 * Update to KDE 3.1.2lioux2003-05-207-151/+175 * Install portsdocs.obraun2003-05-202-0/+13 * Update to 0.6.1.marcus2003-05-193-6/+7 * Add a missing dependency on libxml2.marcus2003-05-191-0/+2 * BROKEN on 5.1: bad C++kris2003-05-181-1/+7 * BROKEN on 5.1: bad C++kris2003-05-181-1/+7 * Update to 1.0.1, a bugfix release.marcus2003-05-172-2/+2 * Update to 2.2.2.marcus2003-05-156-10/+530 * * mutt_vc_query is now available from mail/mutt_vc_query.obraun2003-05-142-1/+11 * Chase libgsf's shared lib version.marcus2003-05-131-2/+2 * upgrade to 1.1ijliao2003-05-1215-84/+147 * - update to 1.06petef2003-05-103-5/+5 * Readd patch-ksimcpu.cpp, which was accidently removed with the 3.1.1 update.arved2003-05-081-0/+11 * Update to 0.8alane2003-05-083-2/+3 * Change LIBS to LDFLAGS to fix the non-GNOME build.marcus2003-05-071-3/+1 * BROKEN: Does not configurekris2003-05-061-0/+2 * Add gdeskcal-skins, a collection of skins for gdeskcal.adamw2003-05-055-0/+133 * Update to 0.50.adamw2003-05-053-2/+25 * Upgrade to 010.obraun2003-05-053-2/+3 * Update to 0.6.0.marcus2003-05-033-8/+17 * Chase guile's shared lib version.marcus2003-05-021-1/+1 * Upgrade to 009.obraun2003-04-262-2/+2 * Update to 4.1.0. New Maintainer: Mike Patterson <mike.patterson@unb.ca>arved2003-04-252-3/+4 * Update to 0.6.1arved2003-04-253-2/+3 * Update WWW and use $MASTER_SITE_SOURCEFORGE.kuriyama2003-04-242-2/+3 * Fix a double-free bug in the logview application. This would be very badmarcus2003-04-244-10/+28 * Update to 0.17.dannyboy2003-04-242-2/+2 * Convert to new GNOME infrastructure.marcus2003-04-223-9/+5 * Update to 0.40.marcus2003-04-222-2/+2 * - rerolled distfile with small source changes and corected ChangeLogdinoex2003-04-201-0/+1 * Upgrade to 008.obraun2003-04-202-2/+3 * Remove USE_GNOMENG.marcus2003-04-1916-16/+0 * - Update to 0.5.1dinoex2003-04-193-17/+3 * Add karamba, a program that displays various information on your KDE desktoparved2003-04-165-0/+44 * Add kbirthday, a kde kicker-applet, that reminds you of birthdays from thearved2003-04-165-0/+48 * Take maintainership in agreement with the submitter/developer.obraun2003-04-141-1/+1 * - Use libobjc.sodinoex2003-04-132-62/+14 * Add rolo 007, text-based contact management software.obraun2003-04-125-0/+35 * * Add a missing dependency on popt [1]marcus2003-04-121-3/+3 * Fix build on CURRENTarved2003-04-091-1/+9 * * Update to new GNOME infrastructuremarcus2003-04-072-10/+4 * Rejoice, for the long awaited upgrade to kde 3.1.1 is here!alane2003-04-0610-58/+43 * Update to version 1.9.2.olgeni2003-04-053-17/+2 * * Update to 1.0.0marcus2003-04-053-25/+3 * Update to 2.2.1.marcus2003-04-046-4/+110 * Update to 0.4.0.marcus2003-04-043-5/+23 * Update to 2.5.petef2003-04-042-2/+2 * Update to 1.0.27.petef2003-04-042-2/+2 * Make sure to run ldconfig -m for each of the module directories at boot time.marcus2003-04-026-0/+63 * - reapply patch that was lost during the update to 0.5dinoex2003-03-311-1/+820 * Update to 0.34.marcus2003-03-302-2/+2 * update for gdeskcal to 0.33,edwin2003-03-292-5/+4 * Add WWW.olgeni2003-03-241-0/+2 * Update to version 1.8.6.deischen2003-03-246-34/+28 * - Update to 0.5dinoex2003-03-242-3/+3 * GWorkspace is the official GNUstep workspace manager. It is a clone ofdinoex2003-03-245-0/+550 * Fix bug in "edit" button handling.olgeni2003-03-232-0/+15 * Fix build: replace BUILD_DEPENDS with EXTRACT_DEPENDS where appropriatelioux2003-03-231-2/+2 * Use a size_t to hold the result of sizeof() instead of an unsigned int.jhb2003-03-191-12/+14 * Correct a typo (s/LIB_DEPEND/LIB_DEPENDS).marcus2003-03-091-1/+2 * Clear moonlight beckons.ade2003-03-0748-24/+24 * - add stamp.makedinoex2003-03-051-0/+4 * - Fix build for CURRENTdinoex2003-03-052-1/+16 * Fix Build on CURRENT.arved2003-03-032-0/+53 * Create locale dirs.marcus2003-03-031-0/+2 * Add gucharmap, a Unicode character map and viewer built on GTK+ 2.marcus2003-03-035-0/+71 * Add ljcharm, a Python CLI interface to LiveJournal servers.marcus2003-03-035-0/+50 * De-uglify the locale installation (somewhat).adamw2003-03-011-27/+5 * Add gnotime, a time tracking application for the GNOME 2 desktop.marcus2003-03-015-0/+152 * Add rubrica, an addressbook for the GNOME 2 desktop.marcus2003-03-018-0/+247 * Update to current-snap-20030224yoichi2003-03-014-4/+4 * Add gdeskcal, a calendar for the GNOME 2 desktop featuring alpha-blending.marcus2003-02-285-0/+129 * deskutils/xcalendar: typosedwin2003-02-272-3/+3 * - Update for gnustep 1.5.2 and gui 0.8.4dinoex2003-02-271-0/+2 * Update to 0.9.1.marcus2003-02-259-6/+39 * De-pkg-commentlioux2003-02-242-1/+1 * Update to 1.91.1.marcus2003-02-244-40/+2 * De-pkg-comment my ports + some more.olgeni2003-02-236-3/+3 * Fix build after QT directory structure change.demon2003-02-231-1/+1 * de-pkg-comment.sanpei2003-02-222-1/+1 * De-pkg-comment.knu2003-02-2150-25/+25 * - retire pkg-commentdinoex2003-02-211-1/+0 * * Re-add libgnomeprint[ui]-2.0 support and unbreakmarcus2003-02-212-5/+3 * - add COMMENTdinoex2003-02-211-0/+1 * De-pkg-comment.knu2003-02-2124-12/+12 * De-pkg-comment and make portlint a little bit happier.obraun2003-02-182-1/+1 * Update to 0.9. MrProject now requires GNOME 2 libraries. The old GNOME 1marcus2003-02-1818-286/+206 * Add libmrproject, the library backend to the MrProject project managementmarcus2003-02-186-0/+100 * add babytrnas 0.9.1ijliao2003-02-138-0/+76 * fix for plist and funky binary name from Volker Stolzalane2003-02-103-4/+5 * Preferences.app is, functionally, a clone of NeXTstep/OPENSTEP tool ofdinoex2003-02-086-0/+135 * Chase libgnomeui's shared lib version.marcus2003-02-081-3/+5 * Update to GNOME 2.2.marcus2003-02-088-52/+70 * Move gnucash from deskutils to finance.marcus2003-02-0613-872/+0 * Install the modules .la files. This is one of the rare exceptions wheremarcus2003-02-053-15/+93 * Update to 1.8.0.marcus2003-02-059-792/+438 * iUpdate homepageedwin2003-02-031-1/+1 * GnuCash no longer requires swig or eperl to build.marcus2003-02-031-2/+0 * Update to 1.0arved2003-02-022-4/+3 * - fix isWarningdirk2003-01-3012-9/+138 * Upgrade to 1.1.dirk2003-01-3012-45/+255 * update to 3.1 official releasealane2003-01-2926-950/+1342 * No need to remove DISTNAMEs which are perfectly reasonable.edwin2003-01-231-0/+1 * The current maintainer does not wish to maintain these ports anymore,petef2003-01-222-3/+1 * Update to 2.0.7.marcus2003-01-206-18/+18 * New port: deskutils/mnemo, a web-based notes and memos application.edwin2003-01-1825-0/+874 * pkg-message -> PKGMESSAGEarved2003-01-172-2/+2 * [MAINTAINER UPDATE] deskutils/mencal 2.0 -> 2.1edwin2003-01-162-3/+3 * Add dependency on gnomeprintui.arved2003-01-161-0/+1 * new port, deskutils/logjam2edwin2003-01-166-0/+34 * Remove the help directories for archive-generator.marcus2003-01-132-0/+6 * Add rox-memo, an appointment/todo manager for the ROX desktop.olgeni2003-01-126-0/+73 * updated to version 0.6alane2003-01-114-26/+13 * Fix a typo (forgot a '%' on a PLIST_SUB variable).petef2003-01-061-1/+1 * Make this fetchable again.marcus2003-01-052-2/+2 * upgrade to 1.1ijliao2003-01-0412-9/+180 * Upgrade to 34.3333.obraun2003-01-033-2/+3 * upgrade to 2.21ijliao2003-01-032-2/+2 * Update to 1.0.b2.1arved2003-01-024-22/+37 * Update to version 0.9.14.001, fix pkg-plist using www/data-distolgeni2003-01-026-11812/+12334 * Fix build on alpha (don't include the klaptop files when we are on alpha,petef2003-01-021-23/+23 * Update to 1.4.9.marcus2003-01-028-64/+28 * A tool for RDF site summaries based news-check.obraun2003-01-026-0/+52 * A tree-structured outliner, note-taker. Written up on unixreview.com thisalane2003-01-017-0/+86 * Use a description that says what programs the gnomepim package contains,adamw2002-12-102-2/+8 * Gak! Replace pre-patch with post-patch to allow gnomehack to do it'smarcus2002-12-032-2/+2 * Mark BROKEN on -CURRENT. Drop Maintainership.arved2002-12-021-3/+9 * Protect post-install target which is redefined by a slave port.kris2002-12-011-0/+2 * * Fix build with Evolution 1.2marcus2002-11-3010-108/+78 * Upgrade port to version 0.9.14.000.olgeni2002-11-246-5758/+10858 * Update holiday information about in coming year 2003.nork2002-11-242-2/+17 * Update to 2.0.6.marcus2002-11-196-6/+8 * Remove BUILD_DEPENDS on gm4 as this is now inherited from devel/bison.marcus2002-11-162-4/+0 * Add a BUILD_DEPENDS on gm4 which fixes a neat build problem onmarcus2002-11-152-0/+4 * Make desktutils/ical building again.edwin2002-11-151-0/+11 * Add libgnomeui-2.0 to LIB_DEPEND.edwin2002-11-151-1/+2 * It seems the previous version of gnomeutils2-2.0.5 was not the right one.marcus2002-11-154-2/+4 * Fix build with the new gtkhtml.marcus2002-11-121-5/+20 * Bump PORTREVISION after the gtkhtml version bump.marcus2002-11-121-0/+1 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-1118-18/+9 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-0718-9/+18 * port wouldn't build without the gnomelibs.edwin2002-11-071-1/+1 * o Fix build error on STABLE due to conflicting definition oflkoeller2002-11-041-0/+19 * Update to a more featurefull, but limited-unless-registered version 3.2.mi2002-11-045-20/+34 * devel/SWIG-devel -> devel/swig13knu2002-10-301-1/+1 * Update deskutils/glabels 1.89.2 -> 1.90.1adamw2002-10-283-8/+8 * Fix build on -current (cope with removal of union wait)kris2002-10-261-0/+11 * add deskutils/glabelsadamw2002-10-227-0/+97 * Remove extraneous '/' from pre-install target.marcus2002-10-162-2/+2 * 1. Removed comments from pkg-plist files per will's request.alane2002-10-115-36/+31 * Fix typo in the commentyoichi2002-10-061-1/+1 * One last commit. Fix the Markus-Brainz line time display in Korgas^Hnizer.alane2002-10-023-0/+87 * 1. Bump PORTREVISION to 1.alane2002-10-022-10/+23 * find->${FIND},xargs->${XARGS}ijliao2002-09-291-1/+1 * Incomplete patch provided. Author doesn't answer mail. Dead.alane2002-09-216-170/+0 * Update to kde3. Bump portrev. Patch by Dave Johnson. Patch manglingalane2002-09-2110-4/+203 * GNOME has just changed the layout of their FTP site. This resulted inmarcus2002-09-214-4/+4 * add mencal 2.0ijliao2002-09-187-0/+57 * Start category Makefile cleanup.alane2002-09-101-1/+0 * Fix things after recent GNOMENG commit.marcus2002-09-101-1/+3 * Update to 1.4.8.marcus2002-09-1010-74/+10 * KDE2 is dead. The source is no longer available.alane2002-09-095-391/+0 * The configure test to see if we have a prototype for strncasecmp() isobrien2002-09-091-0/+5 * Depend on libgmp-freebsd to fix build on -currentkris2002-09-071-0/+2 * Update to 2.0.5.marcus2002-09-074-4/+4 * Deploy USE_GNOMENG infrastructurelioux2002-08-306-9/+15 * Update to 2.0.4.marcus2002-08-294-4/+4 * Directory layouts of py-gtk and py-gnome packages have been changed, so thatsobomax2002-08-291-1/+1 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-2514-123/+8 * Grab all the qt2/kde2 ports with no maintainer and put them under kde@alane2002-08-231-1/+1 * Update to 1.6.8.marcus2002-08-232-2/+2 * Update to 2.0.3.marcus2002-08-216-6/+8 * Update to 1.6.7.sobomax2002-08-186-408/+472 * PERL -> REINPLACE_CMDpat2002-08-08