aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-01-21 05:47:15 +0800
committermarino <marino@FreeBSD.org>2015-01-21 05:47:15 +0800
commit4a19e29519dbf5bcd017ad7952017dc7d72a22b9 (patch)
treec7ac375b937f2b60b84c21b6d9e9bd14e1cfd31a /japanese
parent24134db0d91ba3b32cf1c24d679e9dae909b8ede (diff)
downloadfreebsd-ports-gnome-4a19e29519dbf5bcd017ad7952017dc7d72a22b9.tar.gz
freebsd-ports-gnome-4a19e29519dbf5bcd017ad7952017dc7d72a22b9.tar.zst
freebsd-ports-gnome-4a19e29519dbf5bcd017ad7952017dc7d72a22b9.zip
japanese/ebview-gtk2: Fix size mismatch between int and ssize_t (amd64)
This fetchs the source of segfaults on amd64. PR: 196184 Submitted by: moga (chigusa.homeunix.org)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/ebview-gtk2/Makefile2
-rw-r--r--japanese/ebview-gtk2/files/patch-src_eb.c68
2 files changed, 69 insertions, 1 deletions
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index 2249d3ebabe6..be2fdbe953a1 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ebview
PORTVERSION= 0.3.6
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= japanese
MASTER_SITES= SF
PKGNAMESUFFIX= -gtk2
diff --git a/japanese/ebview-gtk2/files/patch-src_eb.c b/japanese/ebview-gtk2/files/patch-src_eb.c
new file mode 100644
index 000000000000..0f5e51b1db6f
--- /dev/null
+++ b/japanese/ebview-gtk2/files/patch-src_eb.c
@@ -0,0 +1,68 @@
+--- src/eb.c.orig 2014-12-22 16:50:58.000000000 +0900
++++ src/eb.c 2014-12-22 16:54:43.000000000 +0900
+@@ -674,7 +674,8 @@
+ EB_Error_Code error_code=EB_SUCCESS;
+ EB_Position text_position;
+ char data[EB_SIZE_PAGE+4];
+- int i, length;
++ int i;
++ ssize_t length;
+
+ int start_page;
+ int end_page;
+@@ -856,7 +857,8 @@
+ char data[EB_SIZE_PAGE];
+ char *jisword;
+ char *word_p;
+- int i, length;
++ int i;
++ ssize_t length;
+ char *p;
+ char heading[MAXLEN_TEXT + 1];
+ RESULT *rp;
+@@ -1053,7 +1055,7 @@
+ char data[EB_SIZE_PAGE];
+ char *jisword;
+ char *word_p;
+- int length;
++ ssize_t length;
+ char *p;
+ char heading[MAXLEN_TEXT + 1];
+ RESULT *rp;
+@@ -1679,7 +1681,8 @@
+ gint ebook_simple_search2(BOOK_INFO *binfo, char *word, gint method, gchar *title)
+ {
+ EB_Error_Code error_code=EB_SUCCESS;
+- int i, len, total_hits=0;
++ int i, total_hits=0;
++ ssize_t len;
+ EB_Hit hits[MAX_HITS];
+ int hitcount;
+ char heading[MAXLEN_HEADING + 1];
+@@ -1988,7 +1991,7 @@
+ gchar *ebook_get_heading(BOOK_INFO *binfo, int page, int offset)
+ {
+ EB_Error_Code error_code;
+- int len;
++ ssize_t len;
+ char heading[MAXLEN_HEADING + 1];
+ EB_Position position;
+ gchar *p;
+@@ -2021,7 +2024,7 @@
+
+ gchar *ebook_get_text(BOOK_INFO *binfo, int page, int offset){
+ EB_Error_Code error_code;
+- int len;
++ ssize_t len;
+ char text[MAXLEN_TEXT + 1];
+ EB_Position position;
+ gchar *p;
+@@ -2064,7 +2067,7 @@
+ gchar *ebook_get_candidate(BOOK_INFO *binfo, int page, int offset)
+ {
+ EB_Error_Code error_code;
+- int len;
++ ssize_t len;
+ char text[MAXLEN_TEXT + 1];
+ EB_Position position;
+ gchar *p;