aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 13:46:38 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 13:46:38 +0800
commit7dd6805c44bf98d4d64a54313e9f622fd7cb2656 (patch)
tree753b016f246dce9957c268962733d34c7e3eb7b7 /japanese
parentc4fd09e68bc5c2ee1078b7b21b2ac0601f34aead (diff)
downloadfreebsd-ports-gnome-7dd6805c44bf98d4d64a54313e9f622fd7cb2656.tar.gz
freebsd-ports-gnome-7dd6805c44bf98d4d64a54313e9f622fd7cb2656.tar.zst
freebsd-ports-gnome-7dd6805c44bf98d4d64a54313e9f622fd7cb2656.zip
PERL -> REINPLACE
And some ports have USE_PERL5=yes now.
Diffstat (limited to 'japanese')
-rw-r--r--japanese/edict-sdic/Makefile1
-rw-r--r--japanese/linux-JM/Makefile1
-rw-r--r--japanese/today/Makefile3
3 files changed, 4 insertions, 1 deletions
diff --git a/japanese/edict-sdic/Makefile b/japanese/edict-sdic/Makefile
index 26858fa2c5dc..aed688fdb1a4 100644
--- a/japanese/edict-sdic/Makefile
+++ b/japanese/edict-sdic/Makefile
@@ -26,6 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-emacs=mule \
--with-lispdir=${PREFIX}/share/emacs/site-lisp \
--with-dictdir=${PREFIX}/share/dict
+USE_PERL5= yes
post-extract:
${CP} -f ${DISTDIR}/edict.gz ${WRKSRC}
diff --git a/japanese/linux-JM/Makefile b/japanese/linux-JM/Makefile
index b8c4726c0047..4bc0efdd5152 100644
--- a/japanese/linux-JM/Makefile
+++ b/japanese/linux-JM/Makefile
@@ -19,6 +19,7 @@ NO_MTREE= yes
NO_WRKSUBDIR= yes
PLIST= ${WRKDIR}/PLIST
SCRIPTS_ENV+= MANSECS="${MANSECS}"
+USE_PERL5= yes
DATESPEC= 20010415
MANPAGES_GNU= bash gdbm
diff --git a/japanese/today/Makefile b/japanese/today/Makefile
index bfad24f88275..9009763c76b6 100644
--- a/japanese/today/Makefile
+++ b/japanese/today/Makefile
@@ -23,6 +23,7 @@ EXTRACT_BEFORE_ARGS= xfqw=${WRKDIR}
EXTRACT_AFTER_ARGS= # empty
NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
post-extract:
@${ECHO_MSG} "===> Extracting tbl file for ${DISTNAME}"
@@ -43,6 +44,6 @@ pre-patch:
@(${CP} ${FILESDIR}/Makefile ${WRKSRC})
post-patch:
- @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/*.cnf
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/*.cnf
.include <bsd.port.mk>