aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2005-03-07 06:06:12 +0800
committerarved <arved@FreeBSD.org>2005-03-07 06:06:12 +0800
commit940a7fbb22ee0dfe6858d994d48a6e1089d16965 (patch)
tree2de1eec353d8dbcd126534cfed34022024461024 /japanese
parentfa13027adc55ec40f77e4aacc274597af91bea4f (diff)
downloadfreebsd-ports-gnome-940a7fbb22ee0dfe6858d994d48a6e1089d16965.tar.gz
freebsd-ports-gnome-940a7fbb22ee0dfe6858d994d48a6e1089d16965.tar.zst
freebsd-ports-gnome-940a7fbb22ee0dfe6858d994d48a6e1089d16965.zip
* Add the patch to use POSIX termios instead of ioctl,
in order to correctlly run on amd64. * Add w3m wheel mouse patch. PR: 78488 Submitted by: KOMATSU Shinichiro <koma2@ksta.ms.u-tokyo.ac.jp>
Diffstat (limited to 'japanese')
-rw-r--r--japanese/kterm/Makefile6
-rw-r--r--japanese/kterm/distinfo2
-rw-r--r--japanese/kterm/files/patch-scrollbar.c27
3 files changed, 33 insertions, 2 deletions
diff --git a/japanese/kterm/Makefile b/japanese/kterm/Makefile
index 43f7d287dc4c..a53287ffd8b1 100644
--- a/japanese/kterm/Makefile
+++ b/japanese/kterm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kterm
PORTVERSION= 6.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= japanese x11
MASTER_SITES= ${MASTER_SITE_PORTS_JP} \
${MASTER_SITE_XCONTRIB} \
@@ -25,13 +25,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= kterm
PATCH_SITES= ftp://ftp.sra.co.jp/pub/x11/kterm/ \
http://www.asahi-net.or.jp/~hc3j-tkg/kterm/ \
+ http://straycat.ms.u-tokyo.ac.jp/distfiles/ \
${MASTER_SITE_PORTS_JP} \
${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= shige/kterm
PATCHFILES= ${DISTNAME}.NFS-xauth.patch \
${DISTNAME}-wpi.patch.gz \
${DISTNAME}-jisx0213.patch.gz \
- ${DISTNAME}-color16.patch.gz
+ ${DISTNAME}-color16.patch.gz \
+ ${DISTNAME}-termios-0.2.patch.gz
PATCH_DIST_STRIP= -p1
USE_IMAKE= yes
diff --git a/japanese/kterm/distinfo b/japanese/kterm/distinfo
index 26b2e154ca56..28b545486b53 100644
--- a/japanese/kterm/distinfo
+++ b/japanese/kterm/distinfo
@@ -10,3 +10,5 @@ MD5 (kterm/kterm-6.2.0-jisx0213.patch.gz) = c09953e2c8ea1bbb6dbd771ba969cd8b
SIZE (kterm/kterm-6.2.0-jisx0213.patch.gz) = 15530
MD5 (kterm/kterm-6.2.0-color16.patch.gz) = ecf0d363f2d1a253678b77cf41b392ce
SIZE (kterm/kterm-6.2.0-color16.patch.gz) = 1398
+MD5 (kterm/kterm-6.2.0-termios-0.2.patch.gz) = 1af8ea8e6785b339fcc93f92fa783fe9
+SIZE (kterm/kterm-6.2.0-termios-0.2.patch.gz) = 3084
diff --git a/japanese/kterm/files/patch-scrollbar.c b/japanese/kterm/files/patch-scrollbar.c
new file mode 100644
index 000000000000..ed0a87dc7200
--- /dev/null
+++ b/japanese/kterm/files/patch-scrollbar.c
@@ -0,0 +1,27 @@
+--- scrollbar.c.orig Thu Feb 13 02:06:51 2003
++++ scrollbar.c Thu Feb 13 02:07:58 2003
+@@ -46,6 +46,7 @@
+ static void ScrollTextTo();
+ static void ScrollTextUpDownBy();
+
++extern Boolean SendMousePosition();
+
+ /* resize the text window for a terminal screen, modifying the
+ * appropriate WM_SIZE_HINTS and taking advantage of bit gravity.
+@@ -535,6 +536,7 @@
+ XtermWidget w = (XtermWidget) gw;
+ register TScreen *screen = &w->screen;
+
++ if (SendMousePosition(gw, event)) return;
+ ScrollTextUpDownBy (gw, (XtPointer) NULL,
+ (XtPointer)params_to_pixels (screen, params, (int) *nparams));
+ return;
+@@ -551,6 +553,7 @@
+ XtermWidget w = (XtermWidget) gw;
+ register TScreen *screen = &w->screen;
+
++ if (SendMousePosition(gw, event)) return;
+ ScrollTextUpDownBy (gw, (XtPointer) NULL,
+ (XtPointer)-params_to_pixels (screen, params, (int) *nparams));
+ return;
+