aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2007-01-20 23:30:54 +0800
committerume <ume@FreeBSD.org>2007-01-20 23:30:54 +0800
commitc7186c1f5e2e97226f6e566569783639ae61356e (patch)
tree6d28a3deb907941bf508b10f166e3f4ac3d4e232 /japanese
parent11ae3395e3a684940fe4bb6fec734b17f9d23392 (diff)
downloadfreebsd-ports-gnome-c7186c1f5e2e97226f6e566569783639ae61356e.tar.gz
freebsd-ports-gnome-c7186c1f5e2e97226f6e566569783639ae61356e.tar.zst
freebsd-ports-gnome-c7186c1f5e2e97226f6e566569783639ae61356e.zip
Try to fix build on sparc64 by disabling Unihan support.
Reported by: pointyhat via kris
Diffstat (limited to 'japanese')
-rw-r--r--japanese/tomoe/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 43d3c3c5a205..466d2a0561e0 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -25,10 +25,18 @@ USE_RUBY= yes
BUILD_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
+# We cannot use ${ARCH} nor ${UNAME} which are defined in bsd.port.mk, here.
+UNAME= /usr/bin/uname
+ARCH!= ${UNAME} -p
+
OPTIONS=DICT_RUBY "Enable Ruby based dictionary module" off \
EST "Enable Hyper Estraier dictionary module" off \
- MYSQL "Enable MySQL dictionary module" off \
- UNIHAN "Enable Unihan database dictionary module" on
+ MYSQL "Enable MySQL dictionary module" off
+.if ${ARCH} == "sparc64"
+OPTIONS+=UNIHAN "Enable Unihan database dictionary module" off
+.else
+OPTIONS+=UNIHAN "Enable Unihan database dictionary module" on
+.endif
.include <bsd.port.pre.mk>
@@ -55,6 +63,9 @@ PLIST_SUB+= MYSQL="@comment "
.endif
.if defined(WITH_UNIHAN)
+.if ${ARCH} == "sparc64"
+BROKEN= Not buildable with Unihan on sparc64
+.endif
MASTER_SITES+= ftp://ftp.unicode.org/Public/UNIDATA/:unihan
DISTFILES+= Unihan.zip:unihan
EXTRACT_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip