aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-04-25 02:44:37 +0800
committergarga <garga@FreeBSD.org>2006-04-25 02:44:37 +0800
commit0a11d0f6dbaf41480d3f3a5c3ab9d768e44973e6 (patch)
treed85f7cfd7ac12717b9c9c9ef9739e8a99d759239 /japanese
parentba9f8ed47778610dc9f726330990c5e37543d202 (diff)
downloadfreebsd-ports-gnome-0a11d0f6dbaf41480d3f3a5c3ab9d768e44973e6.tar.gz
freebsd-ports-gnome-0a11d0f6dbaf41480d3f3a5c3ab9d768e44973e6.tar.zst
freebsd-ports-gnome-0a11d0f6dbaf41480d3f3a5c3ab9d768e44973e6.zip
Since i can't found a new version for japanese/ming, transfor this port in a
master one instead slave of graphics/ruby-ming and still use ming.so.3. PR: ports/96267 Submitted by: garga Approved by: portmgr (kris)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/ruby-ming/Makefile33
-rw-r--r--japanese/ruby-ming/distinfo3
-rw-r--r--japanese/ruby-ming/pkg-descr10
-rw-r--r--japanese/ruby-ming/pkg-plist25
4 files changed, 68 insertions, 3 deletions
diff --git a/japanese/ruby-ming/Makefile b/japanese/ruby-ming/Makefile
index 554f5097274e..3ed7999484ab 100644
--- a/japanese/ruby-ming/Makefile
+++ b/japanese/ruby-ming/Makefile
@@ -5,13 +5,40 @@
# $FreeBSD$
#
-CATEGORIES= japanese
+PORTNAME= ming
+PORTVERSION= 0.2a.${RUBY_MING_VERSION}
+PORTEPOCH= 1
+CATEGORIES= japanese graphics ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/1765/
PKGNAMEPREFIX= ja-${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-ruby-${RUBY_MING_VERSION}
+DIST_SUBDIR= ruby
+MAINTAINER= don@na.rim.or.jp
COMMENT= Yet another Ming module for Ruby built with Japanese support
LIB_DEPENDS= ming.3:${PORTSDIR}/japanese/ming
-MASTERDIR= ${.CURDIR}/../../graphics/ruby-ming
+RUBY_MING_VERSION= 0.1.6
-.include "${MASTERDIR}/Makefile"
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+CONFIGURE_ARGS= -- --with-ming-include=${PREFIX}/include/ming --with-ming-lib=${PREFIX}/lib
+
+DOCS_EN= ChangeLog README.en Usage_en.txt fonts.en
+DOCS_JA= README.ja Usage_ja.txt fonts.ja progress.rd
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/ruby-ming/distinfo b/japanese/ruby-ming/distinfo
new file mode 100644
index 000000000000..1565ccae0af8
--- /dev/null
+++ b/japanese/ruby-ming/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/ming-ruby-0.1.6.tar.gz) = df39e476dc4b93e8142c510d61369ffd
+SHA256 (ruby/ming-ruby-0.1.6.tar.gz) = 837b09bb2c6768e64314a31795916fa4cc3894c1fcd221434cb7b5d0bf371a94
+SIZE (ruby/ming-ruby-0.1.6.tar.gz) = 42844
diff --git a/japanese/ruby-ming/pkg-descr b/japanese/ruby-ming/pkg-descr
new file mode 100644
index 000000000000..500352440a08
--- /dev/null
+++ b/japanese/ruby-ming/pkg-descr
@@ -0,0 +1,10 @@
+Ming/Ruby is yet another implementation of Ming embedding for Ruby
+extension library without SWIG. Ming/Ruby also supports JaMing which
+is an improvement of Ming to display Japanese characters and to play
+sounds. To use Japanese fonts with JaMing, the letters must be
+followed the UTF-8 formats. Uconv, which is an UTF-8 extension library
+for Ruby, can be used to convert other Kanji encodings into Unicode.
+
+WWW: http://mingruby.rubyforge.org/
+
+Author: Daisuke Ikegami <ikegami@madscientist.jp>
diff --git a/japanese/ruby-ming/pkg-plist b/japanese/ruby-ming/pkg-plist
new file mode 100644
index 000000000000..c3c7c444f119
--- /dev/null
+++ b/japanese/ruby-ming/pkg-plist
@@ -0,0 +1,25 @@
+%%RUBY_SITEARCHLIBDIR%%/ming/ming.so
+@dirrm %%RUBY_SITEARCHLIBDIR%%/ming
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/README
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/action.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/button.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/drag.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/gradient.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/gradientxform.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/keypress.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/mousetrack.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/newbutton.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/shape.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/sparks.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/sprite.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Usage_en.txt
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/fonts.en
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Usage_ja.txt
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/fonts.ja
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/progress.rd
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%