aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-09-19 22:45:01 +0800
committertota <tota@FreeBSD.org>2011-09-19 22:45:01 +0800
commit240de81f1eba9938b258dd0635ab45dc42141ff9 (patch)
tree05c9df1892811cbf860b136d312ef37188a35e07 /japanese
parent7365ad9d393b4f87bc7e04e50c54e05330fd75b8 (diff)
downloadfreebsd-ports-gnome-240de81f1eba9938b258dd0635ab45dc42141ff9.tar.gz
freebsd-ports-gnome-240de81f1eba9938b258dd0635ab45dc42141ff9.tar.zst
freebsd-ports-gnome-240de81f1eba9938b258dd0635ab45dc42141ff9.zip
- Fix pkg-deinstall script [1]
- Bump PORTREVISION, accordingly PR: ports/160414 [1] Submitted by: WATANABE Kazuhiro <CQG00620_AT_nifty_DOT_ne_DOT_jp> [1] Approved by: maintainer
Diffstat (limited to 'japanese')
-rw-r--r--japanese/alias-fonts/Makefile2
-rw-r--r--japanese/alias-fonts/pkg-deinstall6
2 files changed, 5 insertions, 3 deletions
diff --git a/japanese/alias-fonts/Makefile b/japanese/alias-fonts/Makefile
index 9ce7cbee9b71..c60eeba0ca21 100644
--- a/japanese/alias-fonts/Makefile
+++ b/japanese/alias-fonts/Makefile
@@ -7,7 +7,7 @@
PORTNAME= alias-fonts
PORTVERSION= 1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese x11-fonts
MASTER_SITES= # empty
DISTFILES= # empty
diff --git a/japanese/alias-fonts/pkg-deinstall b/japanese/alias-fonts/pkg-deinstall
index 30fef6cb237d..a22d2653fb25 100644
--- a/japanese/alias-fonts/pkg-deinstall
+++ b/japanese/alias-fonts/pkg-deinstall
@@ -1,6 +1,10 @@
#!/bin/sh
# $FreeBSD$
+if [ $2 != "DEINSTALL" ]; then
+ exit 0
+fi
+
dir="${PKG_PREFIX}/lib/X11/fonts/local";
to="$dir/fonts.alias";
from="$to.orig";
@@ -20,5 +24,3 @@ while read line; do
*) echo $line;;
esac
done < $from > $to
-
-rm $from