aboutsummaryrefslogtreecommitdiffstats
path: root/japanese
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-19 06:07:17 +0800
committermarino <marino@FreeBSD.org>2014-06-19 06:07:17 +0800
commitdacfd669baa507b13d47ccf0e691b8b9c9960676 (patch)
tree5dc5964642eeeaf617baf88c9cde633eb0ed17d6 /japanese
parent76c381232aa9ce21a5fd4215aceda4bf3afea0b6 (diff)
downloadfreebsd-ports-gnome-dacfd669baa507b13d47ccf0e691b8b9c9960676.tar.gz
freebsd-ports-gnome-dacfd669baa507b13d47ccf0e691b8b9c9960676.tar.zst
freebsd-ports-gnome-dacfd669baa507b13d47ccf0e691b8b9c9960676.zip
japanese/eb: Always set USES=iconv, move to USES+= libtool
PR: 188218 Submitted by: maintainer (Yasuhiro KIMURA)
Diffstat (limited to 'japanese')
-rw-r--r--japanese/eb/Makefile12
-rw-r--r--japanese/eb/files/patch-eb-book.c15
-rw-r--r--japanese/eb/files/patch-m4-gettext-m480
-rw-r--r--japanese/eb/pkg-plist2
4 files changed, 88 insertions, 21 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index f5f3069485ab..48dd37ed1568 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eb
PORTVERSION= 4.4.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
ftp://ftp.sra.co.jp/pub/misc/eb/old/eb-${PORTVERSION:C/^([0-9]+)\.([0-9]+).*/\1.\2/}/
@@ -63,8 +63,9 @@ PORTDOCS= eb-01.html eb-02.html eb-03.html eb-04.html eb-05.html eb-06.html \
ebzip-03.html ebzip-04.html ebzip-05.html ebzip-06.html ebzip-07.html \
ebzip-08.html ebzip-09.html ebzip-10.html ebzip.html
-USE_AUTOTOOLS= libtool
-USES= perl5 tar:bzip2
+USE_AUTOTOOLS= autoconf autoheader automake aclocal
+ACLOCAL_ARGS= -I ${WRKSRC}/m4
+USES= iconv libtool perl5 tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-pkgdocdir=${DOCSDIR}
@@ -75,13 +76,14 @@ OPTIONS_SUB= yes
APPENDIXDIR= ${DATADIR}/appendix
-NLS_USES= gettext iconv
+NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-NLS_CONFIGURE_ON= \
+NLS_CONFIGURE_ON= \
--with-gettext-includes=${LOCALBASE}/include \
--with-gettext-libraries=${LOCALBASE}/lib \
--with-iconv-includes=${ICONV_PREFIX}/include \
--with-iconv-libraries=${ICONV_PREFIX}/lib
+NLS_CONFIGURE_OFF= --disable-nls
post-extract:
${RM} -fr ${WRKSRC}/zlib
diff --git a/japanese/eb/files/patch-eb-book.c b/japanese/eb/files/patch-eb-book.c
deleted file mode 100644
index 0927dc95ae57..000000000000
--- a/japanese/eb/files/patch-eb-book.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- eb/book.c.orig Sun May 29 09:42:54 2005
-+++ eb/book.c Sun Jul 31 16:06:39 2005
-@@ -658,8 +658,11 @@
- error_code = EB_ERR_FAIL_READ_CAT;
- break;
- }
-- if (*(buffer + 4) == '\0')
-+ if (*(buffer + 4) == '\0') {
-+ strcpy(subbook->sound_file_name, subbook->text_file_name);
-+ strcpy(subbook->graphic_file_name, subbook->text_file_name);
- continue;
-+ }
-
- /*
- * Set a text file name and its compression hint.
diff --git a/japanese/eb/files/patch-m4-gettext-m4 b/japanese/eb/files/patch-m4-gettext-m4
new file mode 100644
index 000000000000..ae2a9bcab759
--- /dev/null
+++ b/japanese/eb/files/patch-m4-gettext-m4
@@ -0,0 +1,80 @@
+--- m4/gettext.m4.orig 2010-01-03 21:26:04.000000000 +0900
++++ m4/gettext.m4 2014-04-03 10:20:12.000000000 +0900
+@@ -87,13 +87,19 @@
+ save_LIBS=$LIBS
+ CPPFLAGS="$save_CPPFLAGS $iconv_includes"
+ LIBS="$save_LIBS $iconv_libraries"
+- AC_CHECK_LIB(iconv, iconv_open,
+- [ICONVLIBS="$iconv_libraries -liconv"; LIBS="$LIBS -liconv"])
+- AC_CHECK_FUNCS(iconv_open locale_charset)
+- AC_CHECK_HEADERS(iconv.h libcharset.h)
+- if test $ac_cv_func_iconv_open != no; then
+- ICONVINCS="$iconv_includes"
+- fi
++ initial_LIBS="$LIBS"
++ AC_SEARCH_LIBS([iconv_open],
++ [iconv],
++ [AS_IF([test "$LIBS" = "$initial_LIBS"],
++ [AC_CHECK_HEADERS([iconv.h])
++ AC_CHECK_FUNCS([iconv_open])
++ ICONVLIBS="$iconv_libraries"
++ ICONVINCS="$iconv_includes"],
++ [AC_CHECK_LIB([charset], [locale_charset])
++ AC_CHECK_HEADERS([iconv.h libcharset.h])
++ AC_CHECK_FUNCS([iconv_open locale_charset])
++ ICONVLIBS="$iconv_libraries -lcharset -liconv"
++ ICONVINCS="$iconv_includes"])])
+ CPPFLAGS=$save_CPPFLAGS
+ LIBS=$save_LIBS
+ AC_SUBST(ICONVINCS)
+@@ -113,10 +119,10 @@
+ save_LIBS=$LIBS
+
+ dnl *
+- dnl * Test 1: Try to link both libintl and libiconv.
++ dnl * Test 1: Try to link libc only.
+ dnl *
+- CPPFLAGS="$save_CPPFLAGS $gettext_includes"
+- LIBS="$save_LIBS $gettext_libraries -lintl $iconv_libraries -liconv"
++ CPPFLAGS="$save_CPPFLAGS"
++ LIBS="$save_LIBS"
+ AC_LINK_IFELSE([
+ #include <stdio.h>
+ #ifdef ENABLE_NLS
+@@ -143,8 +149,8 @@
+ try_nls=yes, try_nls=no)
+
+ if test "$try_nls" = yes; then
+- INTLINCS="$gettext_includes"
+- INTLLIBS="$gettext_libraries -lintl $iconv_libraries -liconv"
++ INTLINCS=
++ INTLLIBS=
+ fi
+
+ dnl *
+@@ -222,11 +228,11 @@
+ fi
+
+ dnl *
+- dnl * Test 4: Try to link libc only.
++ dnl * Test 4: Try to link both libintl and libiconv.
+ dnl *
+ if test "$try_nls" = no; then
+- CPPFLAGS="$save_CPPFLAGS"
+- LIBS="$save_LIBS"
++ CPPFLAGS="$save_CPPFLAGS $gettext_includes"
++ LIBS="$save_LIBS $gettext_libraries -lintl $iconv_libraries -liconv"
+ AC_LINK_IFELSE([
+ #include <stdio.h>
+ #ifdef ENABLE_NLS
+@@ -253,8 +259,8 @@
+ try_nls=yes, try_nls=no)
+
+ if test "$try_nls" = yes; then
+- INTLINCS=
+- INTLLIBS=
++ INTLINCS="$gettext_includes"
++ INTLLIBS="$gettext_libraries -lintl $iconv_libraries -liconv"
+ fi
+ fi
+
diff --git a/japanese/eb/pkg-plist b/japanese/eb/pkg-plist
index 668e1821ad2f..4e076b90c3a5 100644
--- a/japanese/eb/pkg-plist
+++ b/japanese/eb/pkg-plist
@@ -19,9 +19,9 @@ include/eb/text.h
include/eb/zio.h
@dirrm include/eb
lib/libeb.a
-lib/libeb.la
lib/libeb.so
lib/libeb.so.16
+lib/libeb.so.16.0.0
share/aclocal/eb4.m4
%%DATADIR%%/appendix/cencro-1.0/catalog
%%DATADIR%%/appendix/cencro-1.0/catalog.app