aboutsummaryrefslogtreecommitdiffstats
path: root/java/Makefile
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2014-11-14 23:40:15 +0800
committertj <tj@FreeBSD.org>2014-11-14 23:40:15 +0800
commit93afcc37b39da2b1fbef5ae2ccde115ad3ddd6ac (patch)
treef035626e5dcd674ba686f4e9f18c3e3baa461cfb /java/Makefile
parentfe54cbd40c5dd087ea7950fa89d455d7b434194a (diff)
downloadfreebsd-ports-gnome-93afcc37b39da2b1fbef5ae2ccde115ad3ddd6ac.tar.gz
freebsd-ports-gnome-93afcc37b39da2b1fbef5ae2ccde115ad3ddd6ac.tar.zst
freebsd-ports-gnome-93afcc37b39da2b1fbef5ae2ccde115ad3ddd6ac.zip
New port: java/sigar
The Sigar API provides a portable interface for gathering system information such as: * System memory, swap, cpu, load average, uptime, loginsi * Per-process memory, cpu, credential info, state, arguments, environment, open files * File system detection and metrics * Network interface detection, configuration info and metrics * TCP and UDP connection tables * Network route table This information is available in most operating systems, but each OS has their own way(s) providing it. SIGAR provides developers with one API to access this information regardless of the underlying platform. The core API is implemented in pure C with bindings currently implemented for Java, Perl, Ruby, Python, Erlang, PHP and C#. This port provides the Java bindings. WWW: https://support.hyperic.com/display/SIGAR/Home
Diffstat (limited to 'java/Makefile')
-rw-r--r--java/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index fe6673d8aa00..127b0af7a913 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -132,6 +132,7 @@
SUBDIR += sablevm
SUBDIR += sablevm-classpath
SUBDIR += servingxml
+ SUBDIR += sigar
SUBDIR += springframework
SUBDIR += springframework31
SUBDIR += sqlitejdbc