aboutsummaryrefslogtreecommitdiffstats
path: root/java/classpath/Makefile
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-10-06 01:40:54 +0800
committerjkim <jkim@FreeBSD.org>2012-10-06 01:40:54 +0800
commit708483b1ff9f93c22c5722da355808d6f05d0c19 (patch)
tree1dfb2f479537eb416fa59823a49ce75695f35b2a /java/classpath/Makefile
parent6bccac7e36510aa1228286d37ebee44dd6033328 (diff)
downloadfreebsd-ports-gnome-708483b1ff9f93c22c5722da355808d6f05d0c19.tar.gz
freebsd-ports-gnome-708483b1ff9f93c22c5722da355808d6f05d0c19.tar.zst
freebsd-ports-gnome-708483b1ff9f93c22c5722da355808d6f05d0c19.zip
We have to supply -Xmx directly to JVM because ECJ ignores -J option.
http://developer.classpath.org/mediation/ClasspathDeveloperGuidelines
Diffstat (limited to 'java/classpath/Makefile')
-rw-r--r--java/classpath/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 533cee3425f4..0bd118d0da81 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -169,7 +169,7 @@ pre-configure:
@if [ ! -x ${JAVAC} ]; then \
${PRINTF} "%s\n%s\n%s\n%s\n" \
'#!/bin/sh' \
- '"${JAVA}" -classpath "${DISTDIR}/${ECJ_JAR}" \' \
+ '"${JAVA}" -Xmx768M -classpath "${DISTDIR}/${ECJ_JAR}" \' \
' org.eclipse.jdt.internal.compiler.batch.Main \' \
' "$${@:--help}"' > ${JAVAC}; \
${CHMOD} 755 ${JAVAC}; \