aboutsummaryrefslogtreecommitdiffstats
path: root/java/classpath
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-08-29 15:32:46 +0800
committervs <vs@FreeBSD.org>2005-08-29 15:32:46 +0800
commita9a08b2487a8bfb754c5dcd6606554997f50f6e1 (patch)
treea96978a748fe96a72a7e4b764b7d825de06ab892 /java/classpath
parente142d03fbfeb79cfb4242ebd55bd25490d6e6e3d (diff)
downloadfreebsd-ports-gnome-a9a08b2487a8bfb754c5dcd6606554997f50f6e1.tar.gz
freebsd-ports-gnome-a9a08b2487a8bfb754c5dcd6606554997f50f6e1.tar.zst
freebsd-ports-gnome-a9a08b2487a8bfb754c5dcd6606554997f50f6e1.zip
- fix build on 4.x: include missing header
- USE_LIBTOOL, drop ltmain-patch
Diffstat (limited to 'java/classpath')
-rw-r--r--java/classpath/Makefile1
-rw-r--r--java/classpath/files/patch-ltmain.sh15
-rw-r--r--java/classpath/files/patch-native_target_generic_target__generic__network.h13
3 files changed, 14 insertions, 15 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index dc04f9ac1446..9bb6d8a2e925 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -17,6 +17,7 @@ COMMENT= A GNU project to create a free Java class library
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+USE_LIBTOOL_VER=15
USE_GNOME= gtk20 libartlgpl2 pkgconfig
USE_JAVA= yes
USE_JIKES= yes
diff --git a/java/classpath/files/patch-ltmain.sh b/java/classpath/files/patch-ltmain.sh
deleted file mode 100644
index ade64300a950..000000000000
--- a/java/classpath/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Wed Sep 1 15:46:52 2004
-+++ ltmain.sh Wed Sep 1 15:47:02 2004
-@@ -5550,10 +5550,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/java/classpath/files/patch-native_target_generic_target__generic__network.h b/java/classpath/files/patch-native_target_generic_target__generic__network.h
new file mode 100644
index 000000000000..51e4f86d6fa7
--- /dev/null
+++ b/java/classpath/files/patch-native_target_generic_target__generic__network.h
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- native/target/generic/target_generic_network.h.orig
++++ native/target/generic/target_generic_network.h
+@@ -666,6 +666,7 @@
+ #ifndef TARGET_NATIVE_NETWORK_SOCKET_SET_OPTION_SO_TIMEOUT
+ #include <sys/types.h>
+ #include <sys/socket.h>
++ #include <sys/time.h>
+ #define TARGET_NATIVE_NETWORK_SOCKET_SET_OPTION_SO_TIMEOUT(socketDescriptor,flag,result) \
+ do { \
+ struct timeval __value; \