aboutsummaryrefslogtreecommitdiffstats
path: root/java/diablo-jdk15
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2008-07-01 13:47:11 +0800
committerglewis <glewis@FreeBSD.org>2008-07-01 13:47:11 +0800
commitb1cbba58d855af5260f5f9e5d6914c511e2458c7 (patch)
tree1d08a4a6e118868848ec71389c1ea7cfd4a8c84b /java/diablo-jdk15
parent842864da2b9994fcb736411599a656c16d68eb72 (diff)
downloadfreebsd-ports-gnome-b1cbba58d855af5260f5f9e5d6914c511e2458c7.tar.gz
freebsd-ports-gnome-b1cbba58d855af5260f5f9e5d6914c511e2458c7.tar.zst
freebsd-ports-gnome-b1cbba58d855af5260f5f9e5d6914c511e2458c7.zip
. Report when the time zone data is being updated.
. Error if the time zone update fails. This is a bit of a double edged sword. It prevents installing a broken port with a broken packing list if Diablo won't run on this version of FreeBSD, but it also creates a situation where the install can fail without really needing to if you have to retry it for some reason (e.g. you forget the root password when installing as a user). If the latter is the case, you'll need to first clean to before trying to install again to resolve the issue. Making pre-install somewhat bogusly pre-install or checking for the existence of an updated time zone file before running tzupdate may alleviate the problem with this solution. PR: 125085
Diffstat (limited to 'java/diablo-jdk15')
-rw-r--r--java/diablo-jdk15/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/java/diablo-jdk15/Makefile b/java/diablo-jdk15/Makefile
index 5362a06f170b..7cb53f5e315c 100644
--- a/java/diablo-jdk15/Makefile
+++ b/java/diablo-jdk15/Makefile
@@ -106,9 +106,10 @@ post-extract:
@${UNZIP_CMD} -qo ${DISTDIR}/${TZUPDATEFILE} -d ${WRKDIR}
pre-install:
- @# Update time zones
- @-${WRKSRC}/bin/java -jar \
+ @echo -n "Updating time zones..."
+ @${WRKSRC}/bin/java -jar \
${WRKDIR}/tzupdater-${TZUPDATE_VERSION:S/_/./g}-${TZUPDATE_TZVERSION}/tzupdater.jar -u -bc
+ @echo "done"
@-${RM} -rf ${WRKSRC}/jre/lib/zi.tzdata*
.endif