aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-cdt/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2005-09-12 13:33:27 +0800
committerglewis <glewis@FreeBSD.org>2005-09-12 13:33:27 +0800
commitf22e7bf02272179d5818d90b7a3391c1106c575a (patch)
tree3100802773800c1728dab54013e2c111c738edaa /java/eclipse-cdt/Makefile
parent0c9f14e0014e248feef316b9b102c5b778bdbaeb (diff)
downloadfreebsd-ports-gnome-f22e7bf02272179d5818d90b7a3391c1106c575a.tar.gz
freebsd-ports-gnome-f22e7bf02272179d5818d90b7a3391c1106c575a.tar.zst
freebsd-ports-gnome-f22e7bf02272179d5818d90b7a3391c1106c575a.zip
. Update to 3.0.0.
PR: 85300 Submitted by: Panagiotis Astithas <past@ebs.gr>
Diffstat (limited to 'java/eclipse-cdt/Makefile')
-rw-r--r--java/eclipse-cdt/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/java/eclipse-cdt/Makefile b/java/eclipse-cdt/Makefile
index 4ec8daabfed6..fbe5487fd197 100644
--- a/java/eclipse-cdt/Makefile
+++ b/java/eclipse-cdt/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= cdt
-PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTVERSION= 3.0.0
CATEGORIES= java devel
-MASTER_SITES= http://download.eclipse.org/tools/cdt/releases/new/zips/${PORTVERSION}/
+MASTER_SITES= http://download.eclipse.org/tools/cdt/releases/eclipse3.1/dist/${PORTVERSION}/
PKGNAMEPREFIX= eclipse-
DISTNAME= org.eclipse.cdt-${PORTVERSION}-linux.${ECLIPSE_ARCH}
DIST_SUBDIR= eclipse
@@ -21,11 +20,9 @@ RUN_DEPENDS= ${LOCALBASE}/eclipse:${PORTSDIR}/java/eclipse
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_OS= native
-PLIST_SUB= RELEASEVERSION=${PORTVERSION}
ECLIPSE_ARCH= x86
@@ -33,5 +30,8 @@ do-install:
@${MKDIR} ${PREFIX}/eclipse
@${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
@${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
-
+ @(cd ${WRKSRC}; ${FIND} -s eclipse -not -type d) >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse -type d) \
+ | ${GREP} -vE 'eclipse$$|eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
.include <bsd.port.mk>