aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-pmd/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2004-01-10 12:14:06 +0800
committerpetef <petef@FreeBSD.org>2004-01-10 12:14:06 +0800
commitda01eb148d566d2768eefd9dbd004b8b25664fe5 (patch)
tree5520ef9c8ad044fdc89f6291c5e19c70bf071fad /java/eclipse-pmd/Makefile
parent0b00ea7a9243ff7fc3a6b259944cc6f73b89b87f (diff)
downloadfreebsd-ports-gnome-da01eb148d566d2768eefd9dbd004b8b25664fe5.tar.gz
freebsd-ports-gnome-da01eb148d566d2768eefd9dbd004b8b25664fe5.tar.zst
freebsd-ports-gnome-da01eb148d566d2768eefd9dbd004b8b25664fe5.zip
Add eclipse-pmd 1.1.2, scan Java source code and look for potential
problems. PR: 57956 Submitted by: Bruno Van Den Bossche <bruno.van.den.bossche@pandora.be>
Diffstat (limited to 'java/eclipse-pmd/Makefile')
-rw-r--r--java/eclipse-pmd/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/java/eclipse-pmd/Makefile b/java/eclipse-pmd/Makefile
new file mode 100644
index 000000000000..700e728b8e1a
--- /dev/null
+++ b/java/eclipse-pmd/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: eclipse-pmd
+# Date created: October 3, 2003
+# Whom: Bruno Van Den Bossche <bruno.van.den.bossche@pandora.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eclipse-pmd
+PORTVERSION= 1.1.2
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pmd
+DISTNAME= pmd-eclipse-bin-${PORTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Scan Java source code and look for potential problems
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+
+CPIO?= cpio --quiet -pdmu -R
+
+PLUGIN_DIR= "net.sourceforge.pmd.eclipse_${PORTVERSION}"
+
+PLIST_SUB+= PLUGIN_DIR="${PLUGIN_DIR}"
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${MKDIR} ${PREFIX}/eclipse/plugins
+ @${MKDIR} ${PREFIX}/eclipse/plugins/${PLUGIN_DIR}
+ cd ${WRKSRC}/${PLUGIN_DIR} && ${FIND} . \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} \
+ ${PREFIX}/eclipse/plugins/${PLUGIN_DIR}
+
+.include <bsd.port.mk>