aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse-quantum/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2006-01-21 01:05:47 +0800
committerglewis <glewis@FreeBSD.org>2006-01-21 01:05:47 +0800
commite138cdf61db20fb68284b444c5a0909d23fb2a73 (patch)
tree874fdc022e62982dd103b2910cdae06d6d20f12d /java/eclipse-quantum/Makefile
parent522a1d9e37d0e774ce6bbd6404b877e20fe6c589 (diff)
downloadfreebsd-ports-gnome-e138cdf61db20fb68284b444c5a0909d23fb2a73.tar.gz
freebsd-ports-gnome-e138cdf61db20fb68284b444c5a0909d23fb2a73.tar.zst
freebsd-ports-gnome-e138cdf61db20fb68284b444c5a0909d23fb2a73.zip
. Update to 3.0.1.
PR: 91576 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Diffstat (limited to 'java/eclipse-quantum/Makefile')
-rw-r--r--java/eclipse-quantum/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/java/eclipse-quantum/Makefile b/java/eclipse-quantum/Makefile
index ee63977aa91b..cc421c4fb858 100644
--- a/java/eclipse-quantum/Makefile
+++ b/java/eclipse-quantum/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= quantum
-PORTVERSION= 3.0.0
+PORTVERSION= 3.0.1
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= quantum
@@ -17,7 +17,8 @@ DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
COMMENT= Database access and SQL editor for the Eclipse IDE
-RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
+ ${LOCALBASE}/eclipse/features/org.eclipse.gef_3.1.1/feature.xml:${PORTSDIR}/java/eclipse-gef
NO_WRKSUBDIR= yes
NO_BUILD= yes
@@ -28,13 +29,13 @@ USE_ZIP= yes
PLIST_SUB+= VERSION=${PORTVERSION}
post-extract:
- @${RM} ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/Thumbs.db
- @${RM} ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/unused/Thumbs.db
- @${RM} -rf ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/.xvpics
+ @${RM} ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/Thumbs.db
+ @${RM} ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/unused/Thumbs.db
+ @${RM} -rf ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/.xvpics
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
.include <bsd.port.mk>