aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse/Makefile
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-09-14 22:46:36 +0800
committernork <nork@FreeBSD.org>2005-09-14 22:46:36 +0800
commitb312012881a2cc1bfabb919ef593cf8e3a823ca6 (patch)
tree951e8aff17ae38c391f952e76006270f6a2d905c /java/eclipse/Makefile
parent5948082f5a9bfc66adfe1fe30f6543e1341e901b (diff)
downloadfreebsd-ports-gnome-b312012881a2cc1bfabb919ef593cf8e3a823ca6.tar.gz
freebsd-ports-gnome-b312012881a2cc1bfabb919ef593cf8e3a823ca6.tar.zst
freebsd-ports-gnome-b312012881a2cc1bfabb919ef593cf8e3a823ca6.zip
Fix build error WITH_MOTIF.
Add a desktop meny entry under GNOME. PR: ports/86086 Submitted by: Panagiotis Astithas <past@ebs.gr>
Diffstat (limited to 'java/eclipse/Makefile')
-rw-r--r--java/eclipse/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 9be9a4e09891..445e679b66d8 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-${PORTVERSION}-200506271435
@@ -90,9 +90,10 @@ MAKE_ENV+= BROWSER=${BROWSER} \
MAKE_GNOME=${MAKE_GNOME} \
MAKE_MOZILLA=${MAKE_MOZILLA} \
MAKE_CAIRO=${MAKE_CAIRO} \
+ MACHINE_ARCH=${MACHINE_ARCH} \
MOTIF_HOME=${X11_HOME}
-PLIST_FILES= bin/eclipse
+PLIST_FILES= bin/eclipse share/gnome/applications/eclipse.desktop
SWTGTK=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library
SWTMOTIF=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/motif/library
@@ -122,6 +123,11 @@ do-install:
-e "s+%%BROWSER%%+${BROWSER}+g" \
${FILESDIR}/eclipse.in > ${WRKSRC}/eclipse.tmp
${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/eclipse
+ @${SED} \
+ -e "s+%%ECLIPSE_HOME%%+${PORTDESTDIR}+g" \
+ -e "s+%%PREFIX%%+${PREFIX}+g" \
+ ${FILESDIR}/eclipse.desktop > ${WRKSRC}/eclipse.desktop.tmp
+ ${INSTALL_DATA} ${WRKSRC}/eclipse.desktop.tmp ${X11BASE}/share/gnome/applications/eclipse.desktop
${INSTALL_PROGRAM} ${WRKSRC}/launchertmp/eclipse ${PREFIX}/eclipse/eclipse
@(cd ${WRKSRC}; ${FIND} -s eclipse -not -type d) >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse -type d) \