aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2012-09-19 17:16:03 +0800
committerale <ale@FreeBSD.org>2012-09-19 17:16:03 +0800
commit7187412ed9cc5165d6896becf20b6f8c1b537149 (patch)
tree05969938c12c86f1c182ada3fb8eeef9986c4f9c /java/eclipse
parent2b46fe5ff9a183d7137283d40c6f5d925d3bd4d9 (diff)
downloadfreebsd-ports-gnome-7187412ed9cc5165d6896becf20b6f8c1b537149.tar.gz
freebsd-ports-gnome-7187412ed9cc5165d6896becf20b6f8c1b537149.tar.zst
freebsd-ports-gnome-7187412ed9cc5165d6896becf20b6f8c1b537149.zip
Fix wrong permissions on a few plugin jars.
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 2568703f606c..0567762babdf 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse
PORTVERSION= 3.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/3.7.x_Indigo/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/:2 \
@@ -245,6 +245,7 @@ do-install:
@${MKDIR} ${PORTDESTDIR}
@${MKDIR} ${PREFIX}/${DROPINS_DIR}
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} ${INSTALL_TARGET})
+ @${FIND} ${PORTDESTDIR}/plugins -type f -perm 600 -print0 | ${XARGS} -0 ${CHMOD} 644
@${SED} \
-e "s+%%BROWSER%%+${GECKO:S/19//}+g" \
-e "s+%%ECLIPSE_HOME%%+${PORTDESTDIR}+g" \