aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-09-07 16:40:13 +0800
committerale <ale@FreeBSD.org>2010-09-07 16:40:13 +0800
commitb47637791655c748a67b9400be3ae41d0852b3cc (patch)
tree2a7e712817954d209278052030212a3eabbde2b7 /java/eclipse
parent05e5f609a646fa8fcfd9539cb3724624207dcc1d (diff)
downloadfreebsd-ports-gnome-b47637791655c748a67b9400be3ae41d0852b3cc.tar.gz
freebsd-ports-gnome-b47637791655c748a67b9400be3ae41d0852b3cc.tar.zst
freebsd-ports-gnome-b47637791655c748a67b9400be3ae41d0852b3cc.zip
Add a common Makefile to simplify installing eclipse plugins in the
correct equinox dropins directory.
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile1
-rw-r--r--java/eclipse/Makefile.plugins13
2 files changed, 14 insertions, 0 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 77edc3d51006..6adf8c107643 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -222,6 +222,7 @@ do-install:
-@update-desktop-database
@(cd ${PREFIX}; ${FIND} -s lib/${PORTNAME} -not -type d) >> ${TMPPLIST}
@(cd ${PREFIX}; ${FIND} -s -d lib/${PORTNAME} -type d) | ${SED} -ne "s,^,@dirrm ,p" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${MKDIR} %D/share/${PORTNAME}/dropins 2> /dev/null || /usr/bin/true" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/${PORTNAME}/dropins 2>/dev/null || true " >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ${RMDIR} %D/share/${PORTNAME} 2>/dev/null || true " >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${PREFIX}/bin/update-desktop-database > /dev/null || /usr/bin/true" >> ${TMPPLIST}
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
new file mode 100644
index 000000000000..73dc1993d181
--- /dev/null
+++ b/java/eclipse/Makefile.plugins
@@ -0,0 +1,13 @@
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6
+JAVA_OS= native
+
+REPO_DIRS?= features plugins
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
+ @(cd ${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
+ @(cd ${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}